Bug 72932 - no/too long timeout in autofs
no/too long timeout in autofs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 03:30 EDT by Andrej Vodopivec
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 17:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Vodopivec 2002-08-29 03:30:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
The first thing I tried with null was autofs. If 7.3 turning off
workstation 'sprint' with disks automounted on my test workstation
slowed down the computer to snails pace untils reboot. With null this
is better: only the application requesting data is stopped for >5
minutes. I did not wait longer to see if the shell in the terminal
where I ran 'ls /home/sprint'. On Solaris it returns with no data in
about 60 seconds.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
	1. start NIS
2. automount a disk with ls
3. shutdown the workstation exporting the disk
4. run ls

Actual Results:  shell doesn't return a prompt for >5 minuts.
Can not be interruped with ^C.

Expected Results:  No files listed, shell prompt after some timeout.

Additional info:
Comment 1 Andrej Vodopivec 2002-08-30 04:15:05 EDT
The same problem arises on halt/reboot. The shutdown procedure hangs (I waited
15+ minutes) with:
nfs: server stil not responding, still trying
Andrej
Comment 2 Jeffrey Moyer 2004-03-22 10:29:10 EST
Sounds like a kernel nfs issue, to me.
Comment 3 Jeffrey Moyer 2004-03-24 09:16:29 EST
Can you reproduce this with Fedora or one of our enterprise offerrings?
Comment 4 Jeffrey Moyer 2004-05-11 17:25:19 EDT
use thre intr option for your nfs mounts.

Note You need to log in before you can comment on or make changes to this bug.