This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 729337 - Administration-->System Settings ....globally uncaught exception
Administration-->System Settings ....globally uncaught exception
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
All All
urgent Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-09 11:02 EDT by Mike Foley
Modified: 2013-08-05 20:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
globally uncaught exception looking at system settings (73.72 KB, image/png)
2011-08-09 11:02 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-08-09 11:02:49 EDT
Created attachment 517425 [details]
globally uncaught exception looking at system settings

Description of problem:  Administration-->System Settings ....globally uncaught exception


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  top menu...Administration
2.  System Settings
3.
  
Actual results:

uncaught exception

Expected results:

no uncaught exceptions during navigation of the UI

Additional info:
Globally uncaught exception
Severity :	
Error
	
Time :	
Tuesday, August 9, 2011 10:58:12 AM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): this.form is null stack: isc_FormItem_saveValue("RHQ",(void 0))@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1214 isc_FormItem_setValue("RHQ")@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1221 com_smartgwt_client_widgets_form_fields_FormItem_$setValue__Lcom_smartgwt_client_widgets_form_fields_FormItem_2Ljava_lang_String_2V([object Object],"RHQ")@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:20766 org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_2Lorg_rhq_core_domain_common_ServerDetails_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:54361 org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:54386 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:156641 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js lineNumber: 1214
--- STACK TRACE FOLLOWS ---
(TypeError): this.form is null stack: isc_FormItem_saveValue("RHQ",(void 0))@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1214 isc_FormItem_setValue("RHQ")@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js:1221 com_smartgwt_client_widgets_form_fields_FormItem_$setValue__Lcom_smartgwt_client_widgets_form_fields_FormItem_2Ljava_lang_String_2V([object Object],"RHQ")@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:20766 org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_2Lorg_rhq_core_domain_common_ServerDetails_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:54361 org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:54386 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:156641 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/95F9C3E45766D51DADAB191A06D48E95.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js lineNumber: 1214
    at Unknown.isc_FormItem_saveValue(Unknown source:0)
    at Unknown.isc_FormItem_setValue(Unknown source:0)
    at Unknown.com_smartgwt_client_widgets_form_fields_FormItem_$setValue__Lcom_smartgwt_client_widgets_form_fields_FormItem_2Ljava_lang_String_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_2Lorg_rhq_core_domain_common_ServerDetails_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_admin_SystemSettingsView$3_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.handleEvent(Unknown source:0)
    at Unknown.SJOWContentBoundary(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 1 Ian Springer 2011-08-15 10:48:55 EDT
I went to the System Settings page 15 or 20 times but was unable to reproduce this. However, I think I know how it could sometimes occur. The values of the fields of the system details form were being set using formItem.setValue(). This works fine if the form has been added to its parent Canvas first, but this will not be the case if the async call that loads the system details returns before the form has been added, in which case the "this.form is null" errors occurs because the FormItems are not yet officially attached to the form.

[master 3281da4] (http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=3281da4) uses Form.setValue(), rather than FormItem.setValue() to set the values, which should prevent the error from occurring.
Comment 2 Mike Foley 2011-08-15 13:29:02 EDT
verified through "quick clicking" ... 08/15 build.
Comment 3 Mike Foley 2012-02-07 14:27:47 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.