Bug 729342 - 'SSLCertificateVerifyFailedError' object has no attribute 'errmsg' in case the server's SSL certificate validation failed
Summary: 'SSLCertificateVerifyFailedError' object has no attribute 'errmsg' in case th...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Keywords:
: 745008 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 15:31 UTC by Milan Zázrivec
Modified: 2018-12-04 08:51 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-06-20 11:59:25 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Milan Zázrivec 2011-08-09 15:31:24 UTC
Description of problem:
In case client is setup to use SSL for server connection and server's
SSL certificate validation failed (for whatever reason), following traceback
is printed into /var/log/up2date:

Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 76, in <module>
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 74, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 58, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1272, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1230, in run
    result = win.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 235, in run
    tui_call_wrapper(self.screen, rhnreg.getCaps)
  File "/usr/share/rhn/up2date_client/tui.py", line 85, in tui_call_wrapper
    FatalErrorWindow(screen, e.errmsg)
<type 'exceptions.AttributeError'>: 'SSLCertificateVerifyFailedError' object has no attribute 'errmsg'

Note the following two lines in there:

    FatalErrorWindow(screen, e.errmsg)

and
    <type 'exceptions.AttributeError'>: 'SSLCertificateVerifyFailedError' object has no attribute 'errmsg'

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0-61.el6

How reproducible:
Always

Steps to Reproduce:
1. Client -> Server connection using SSL, simulate failure of SSL validation
(point the client to an incorrect CA certificate for example)
2. Run rhn_register
3. Watch /var/log/up2date
  
Actual results:
Traceback above.

Expected results:
Error message about SSL validation, but no traceback telling us we called
a non-existent attribute.

Additional info:
N/A

Comment 1 RHEL Product and Program Management 2011-10-07 16:04:20 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 2 Jan Pazdziora 2011-11-24 13:47:23 UTC
*** Bug 745008 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Suchý 2012-01-03 10:59:29 UTC
This was fixed in bug 759786. Leaving this open as just another use case to test.

Comment 8 Miroslav Suchý 2012-01-27 15:17:45 UTC
spacewalk.git commit 9b28ded9de35b00d05457c877b8e8bb9d68a37de

Comment 9 Miroslav Suchý 2012-01-27 15:52:31 UTC
cherry-picked to satellite.git as 5f578220fcbf0cd5ab010eca9166e91c2c68f047

Comment 12 errata-xmlrpc 2012-06-20 11:59:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html

Comment 13 jalviso 2012-11-07 02:41:56 UTC
Hi,

Is this errata fix applicable to RHEL 5 systems?

Regards,

Josephine Alviso
APAC - Brisbane

Comment 14 Jan Pazdziora 2012-11-07 06:53:45 UTC
(In reply to comment #13)
> 
> Is this errata fix applicable to RHEL 5 systems?

I don't remember this issue ever being present on RHEL 5 systems. Do you have a customer case to suggest otherwise?

Comment 15 jalviso 2012-11-07 07:10:23 UTC
Hi Jan,

Yes, I have a support case 00722972. Customer gets this error: "exceptions.AttributeError: SSLCertificateVerifyFailedError instance has no attribute 'errmsg'" in the up2date log when trying to register a RHEL 5.3 system.

Josephine

Comment 16 Jan Pazdziora 2012-11-07 07:18:56 UTC
What rhn-client-tools version is this?

Comment 17 jalviso 2012-12-11 02:44:35 UTC
Hi Jan,

Sorry for the late reply. Customer installed:

rhn-client-tools-0.4.20-77.el5.noarch 

Would this errata, http://rhn.redhat.com/errata/RHBA-2012-0752.html.
applicable to Red Hat Enterprise Linux Client release 5.8?

Thanks.

Josephine

Comment 18 Jan Pazdziora 2012-12-11 08:47:17 UTC
(In reply to comment #17)
> 
> Sorry for the late reply. Customer installed:
> 
> rhn-client-tools-0.4.20-77.el5.noarch 

Good. That is the latest greatest for RHEL 5. If the problem persists for your customer, we will need new RHEL 5 bugzilla filed.

> Would this errata, http://rhn.redhat.com/errata/RHBA-2012-0752.html.
> applicable to Red Hat Enterprise Linux Client release 5.8?

No.


Note You need to log in before you can comment on or make changes to this bug.