Bug 729344 - Provide native systemd service files
Provide native systemd service files
Status: CLOSED DUPLICATE of bug 884641
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-08-09 11:56 EDT by Jóhann B. Guðmundsson
Modified: 2013-03-04 07:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 07:46:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups-lpd systemd socket (120 bytes, text/plain)
2011-08-09 12:07 EDT, Jóhann B. Guðmundsson
no flags Details
cups-lpd@.service for the socket (157 bytes, text/plain)
2011-08-09 12:08 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-08-09 11:56:18 EDT
Description of problem:

As discussed a bit on irc here are the unit files 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-08-09 12:07:29 EDT
Created attachment 517441 [details]
cups-lpd systemd socket
Comment 2 Jóhann B. Guðmundsson 2011-08-09 12:08:12 EDT
Created attachment 517443 [details]
cups-lpd@.service for the socket
Comment 3 Jóhann B. Guðmundsson 2011-08-09 12:10:58 EDT
To test this drop the cups-lpd@.service and cups-lpd.socket file into /lib/systemd/system

and run 

# systemctl daemon-reload && systemctl start cups-lpd.socket 

I only tested telnet to port 515 and that worked so you guys need to test some legacy use-cases that are used with cups-lpd :)
Comment 4 Jóhann B. Guðmundsson 2011-09-10 07:44:05 EDT
Once package and shipped you package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
Comment 5 Jiri Popelka 2013-03-04 07:46:38 EST
Whoops, I hadn't noticed this one before filling bug #884641.

*** This bug has been marked as a duplicate of bug 884641 ***

Note You need to log in before you can comment on or make changes to this bug.