Bug 729348 - [vdsm] vdsm log directory is created with root owner on vdsm startup
Summary: [vdsm] vdsm log directory is created with root owner on vdsm startup
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 16:10 UTC by Jakub Libosvar
Modified: 2012-10-30 13:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-30 13:55:46 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Jakub Libosvar 2011-08-09 16:10:12 UTC
Description of problem:
During my clean-up I deleted /var/log/vdsm directory. I didn't installed or updated vdsm. After I restarted vdsm, it could not start cause /var/log/vdsm has root owner insted of qemu:kvm

Version-Release number of selected component (if applicable):
vdsm-4.9-91

How reproducible:
Always

Steps to Reproduce:
On host:
1. service vdsmd stop
2. rm -rf /var/log/vdsm
3. service vdsmd start
  
Actual results:
/var/log/vdsm has owner root:root

Expected results:
owner is 36:36 (qemu:kvm)

Additional info:
Note that start of service says that vdsm started OK but actually it immediately exits due to logging issues.

Comment 2 Dan Kenigsberg 2011-08-10 07:24:36 UTC
It is interesting to see how vdsm behaves if you

rm -rf /

instead of your original step 2. </evil grin>

(yeah, it would be nice to chown /var/log/vdsm when we recreate /var/log/vdsm/backup/)

Comment 3 Ryan Harper 2012-09-12 15:42:15 UTC
Potential fix posted:

http://gerrit.ovirt.org/#/c/7940/


Note You need to log in before you can comment on or make changes to this bug.