Bug 729359 - Not releasing IPv6 leases - wrong PID file name.
Summary: Not releasing IPv6 leases - wrong PID file name.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.2
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 729292
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 16:33 UTC by Bill Nottingham
Modified: 2014-09-08 12:40 UTC (History)
7 users (show)

Fixed In Version: initscripts-9.03.24-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 729292
Environment:
Last Closed: 2011-12-06 18:10:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1528 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2011-12-06 01:02:05 UTC

Description Bill Nottingham 2011-08-09 16:33:57 UTC
+++ This bug was initially created as a clone of Bug #729292 +++

Description of problem:
While experimenting with IPv6, DHCP & DDNS, I noticed a typo in /etc/sysconfig/network-scripts/ifdown-eth.
In the stanza handling dhclient shutdown (line 73) the PID file name passed to dhclient does not include the IP version prefix. IPv4 is closed first, removing it's PID file, then IPv6 is closed using the (now removed) IPv4 PID file.

Version-Release number of selected component (if applicable):
initscripts-9.20.2-1.fc14.1.x86_64

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:
/sbin/dhclient -r -lf /var/lib/dhclient/dhclient$VER-${DEVICE}.leases -pf /var/run/dhclient-${DEVICE}.pid ${DEVICE} >/dev/null 2>&1

Expected results:
/sbin/dhclient -r -lf /var/lib/dhclient/dhclient$VER-${DEVICE}.leases -pf /var/run/dhclient$VER-${DEVICE}.pid ${DEVICE} >/dev/null 2>&1

Additional info:
Quick diff -u:
--- ifdown-eth.daveg	2011-02-25 20:23:36.000000000 +0000
+++ ifdown-eth	2011-08-09 12:41:23.747160554 +0100
@@ -70,7 +70,7 @@
 	if [ -f "/var/run/dhclient$VER-${DEVICE}.pid" ]; then
 		dhcpid=$(cat /var/run/dhclient$VER-${DEVICE}.pid)
 		if [[ "$DHCPRELEASE" = [yY1]* ]];  then
-			/sbin/dhclient -r -lf /var/lib/dhclient/dhclient$VER-${DEVICE}.leases -pf /var/run/dhclient-${DEVICE}.pid ${DEVICE} >/dev/null 2>&1
+			/sbin/dhclient -r -lf /var/lib/dhclient/dhclient$VER-${DEVICE}.leases -pf /var/run/dhclient$VER-${DEVICE}.pid ${DEVICE} >/dev/null 2>&1
 			retcode=$?
 		else
 			kill $dhcpid >/dev/null 2>&1

--DaveG.

--- Additional comment from notting@redhat.com on 2011-08-09 12:32:45 EDT ---

Thanks for the patch! Added to rawhide, F-15, and F-14 branches, will be in some future update.

Comment 1 Bill Nottingham 2011-08-09 16:34:31 UTC
This is git commit 53da814.

Comment 4 errata-xmlrpc 2011-12-06 18:10:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1528.html


Note You need to log in before you can comment on or make changes to this bug.