Bug 729381 - memory corruption handling the acpitable command line option, leads to segfault
memory corruption handling the acpitable command line option, leads to segfault
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-08-09 13:53 EDT by David Mansfield
Modified: 2013-12-08 19:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-08 11:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix realloc bug leading to segmentation fault (821 bytes, patch)
2011-08-09 13:53 EDT, David Mansfield
no flags Details | Diff

  None (edit)
Description David Mansfield 2011-08-09 13:53:39 EDT
Created attachment 517455 [details]
patch to fix realloc bug leading to segmentation fault

Description of problem:
when using the -acpitable option to qemu-kvm, memory corruption occurs and quite often a segmentation fault.  this is due to mis-use of "realloc".  this has been fixed upstream.

a least impact patch is attached.

Version-Release number of selected component (if applicable):
kvm-83-224.el5.1

How reproducible:
seems to depend a bit on the machine, because sometimes realloc will return the original pointer.  on two machines here, it always happens on one, never on the other.

Steps to Reproduce:
1. /usr/libexec/qemu-kvm -acpitable x /dev/null
2.
3.
  
Actual results:
segmentation fault

Expected results:
pops up "console" window


Additional info:
i have attached the "least impact" fix for the bug.

see also the upstream commit:

http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commitdiff;h=d729bb9a7700e364b1c5f9893d61f07a9e002bce
Comment 1 Ronen Hod 2011-08-11 08:04:10 EDT
Not closed for RHEL5.8 only since it looks like an easy fix. If any complications arise we might decide to skip it.
Comment 3 RHEL Product and Program Management 2012-04-02 06:53:24 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Ronen Hod 2012-04-08 11:15:11 EDT
David Mansfield,

Thank you for taking the time to enter a bug report with us. We do appreciate the feedback and look to use reports such as this to guide our efforts at improving our products.
We decided to close this bug, since in order to keep RHEL5.9 stable we avoid fixing non-urgent bugs.
 
If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain that it gets the proper attention and prioritization to assure a timely resolution. 
 
For information on how to contact the Red Hat production support team, please see:
https://www.redhat.com/support/process/production/#howto

Thanks, Ronen.

Note You need to log in before you can comment on or make changes to this bug.