Bug 729385 - Cannot install icedtea-web on i686 Rawhide
Summary: Cannot install icedtea-web on i686 Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: icedtea-web
Version: rawhide
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 18:06 UTC by Jerry James
Modified: 2011-08-09 18:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-09 18:33:36 UTC


Attachments (Terms of Use)

Description Jerry James 2011-08-09 18:06:28 UTC
Description of problem:
The following happens on an i686 machine.  It does NOT happen on an otherwise identical x86_64 machine.

# yum install icedtea-web
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package icedtea-web.i686 0:1.1.1-1.fc17 will be installed
--> Processing Dependency: 098cc7786ee477c8eaee0a0c23cfb793d220f7.debug for package: icedtea-web-1.1.1-1.fc17.i686
--> Finished Dependency Resolution
Error: Package: icedtea-web-1.1.1-1.fc17.i686 (rawhide)
           Requires: 098cc7786ee477c8eaee0a0c23cfb793d220f7.debug
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
icedtea-web-1.1.1-1.fc17

How reproducible:
Always

Steps to Reproduce:
1. If icedtea-web is already install, "yum upgrade icedtea-web".
2. Otherwise, "yum install icedtea-web"
3.
  
Actual results:
Failure to install or upgrade, due to the dependency on a debug name.

Expected results:
Installed or upgraded icedtea-web package.

Additional info:
Enabling the rawhide-debuginfo repository doesn't help, as icedteaweb-debuginfo does not provide the debug name.

Comment 1 Deepak Bhole 2011-08-09 18:33:36 UTC
Thanks for reporting. 

Fixed in F16 and rawhide in icedtea-web-1.1.1-2


Note You need to log in before you can comment on or make changes to this bug.