Bug 7294 - Can not install RH6.1 on Thinkpad 770z with 13GB IDE harddrive
Can not install RH6.1 on Thinkpad 770z with 13GB IDE harddrive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 11:56 EST by John Constantinos Bacas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 17:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Constantinos Bacas 1999-11-24 11:56:00 EST
When trying to install RH 6.1 on IBM Thainkpad 770z with a 13GB harddrive
all that you get is "unable to read" errors from ?(fdisk/diskdruid). It
appers that the stock IDE drivers blow the geometry and report it as
1023,63,16 when it should be 1826,240,63. This prevents installation. A
circumvention appears to be to install to other drive as secondard IDE
device, then upgrade to 2.2.13 kernel (still does not work on large drive),
or 2.3.28 kernel (IDE works well, other things do not compile). When the
2.2.13 kernel is patched with the ide-2.2.13-19991111 patch file the system
then works correctly. It is now able to read the primary drive, and the
msdos, vfat and hpfs file systems that already exist on that drive. The
concern that I have is if the patch that was applied is considered stable,
or am I risking damage to the hpfs and dos partitions that are on the
drive? If there is another way to rebuild this system with a new boot disk
I would appreciate some direction since every kernel that I have built is
too big to fit on a floppy and I am not sure how to rebuild the
installation initrd file. Also it is prety tedious to do a remote install
thru pcmcia to a cdrom on a different box. Any help/ideas/pointers would be
greatly appreciated.

Thanks
Comment 1 Cristian Gafton 2000-01-04 17:20:59 EST
Assigned to dledford
Comment 2 Alan Cox 2000-08-22 10:45:51 EDT
6.2 is able to do this by default now

Note You need to log in before you can comment on or make changes to this bug.