Bug 72940 - Limbo setup only allows for built-in touchpad on a laptop with an additional USB mouse
Limbo setup only allows for built-in touchpad on a laptop with an additional ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Preston Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 05:41 EDT by Felipe Alfaro Solana
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 14:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2002-08-29 05:41:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020820

Description of problem:
I have a laptop with a built-in, PS/2-style, touchpad mouse, and a Microsoft
Intellimouse USB Explorer mouse attached to one of the free USB ports. During
installation of Limbo (July, 26th), the graphical setup does only setup and
recognise the built-in touchpad, not allowing me to use the external USB mouse.

This is really a curious behavior since the mouse seems to be recognized: It's
an Intellimouse Optical USB mouse and, when it's detected, the red light at the
bottom of the mouse is lit. During RedHat Limbo setup, the mouse light is on,
making me think it has been detected but not properly enabled.

I suggest adding a new "InputSection Mouse1" on the XF86Config file used by
anaconda/RH GUI installer pointing to "/dev/input/mice" with the
"SendCoreEvents" option. This would overcome this limitation. This is how I have
configured my production RH73 system: when the external USB mouse is not
attached, the X server will simply ignore it, still allowing the use of the
built-in mouse. Maybe this needs more work on the real anaconda/RH installer,
but I think the idea is still valid.

Adding this little configuration option to the Graphical Installation of Limbo
would allow the user of two mouses, while not disturbing normal operation for
users of machines with a single mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Gain access to a laptop with a built-in mouse and a USB port
2. Attach a USB mouse - like a MS Intellimouse USB Explorer - to it
3. Boot RedHat Limbo installation from CD
4. Once the Graphical Interface of the RH/Limbo installation has started, you
should be able to use the laptop's built-in mouse, but the external USB mouse
won't be usable.
	

Actual Results:  Only the built-in mouse is usable. The external USB mouse is
not configured - although I bet it has been detected correctly.

Expected Results:  On machines with a built-in mouse that can't be disabled,
adding an additional, external USB mouse won't allow the user to use it during
the Graphical installation of RedHat Limbo.

However, after the installation has finished (and even on the Test Settings of
the X Server configuration stage at the very end of the installation), both
mouses are usable and feed input events onto the X Server.

Additional info:
Comment 1 Bill Nottingham 2002-08-29 14:32:51 EDT
I believe this was changed for (null) to set up a secondary pointer for the
installer. Can you retest with that?
Comment 2 Felipe Alfaro Solana 2002-08-31 08:16:55 EDT
Yes, this has been fixed in Null... During installation I can use both the
huilt-in, PS/2-style touchpad and my external USB mouse. Thanks!

Note You need to log in before you can comment on or make changes to this bug.