Bug 729405 - Missing wifi (iwlagn) when at kernel 2.6.40-4.fc15.x86_64 - 11n_disable50
Summary: Missing wifi (iwlagn) when at kernel 2.6.40-4.fc15.x86_64 - 11n_disable50
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 18:18 UTC by Joakim Hovlandsvåg
Modified: 2011-08-09 19:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-09 19:19:35 UTC


Attachments (Terms of Use)
What dmesg is saying (if of any help) (77.27 KB, text/plain)
2011-08-09 18:22 UTC, Joakim Hovlandsvåg
no flags Details

Description Joakim Hovlandsvåg 2011-08-09 18:18:40 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

After upgrading to kernel 2.6.40-4.fc15.x86_64 the wifi is missing, and no wlan0 or anything similar exists in `ifconfig -a`. When starting up with the older kernel version (2.6.38.8-35.fc15.x86_64), the wifi is working ok.

The wired network is unaffected.

Reproducible: Always

Steps to Reproduce:
1. Upgrading the yum packages, so the latest kernel is added.
2. Reboot with kernel 2.6.40-4.fc15.x86_64 with existing wireless card.
Actual Results:  
The wireless card is not being set up, ie. it isn't reachable as e.g. 'wlan0'.


The laptop is an HP EliteBook 6930p, preupgraded from fedora14, and the network card is "Intel Corporation PRO/Wireless 5100 AGN [Shiloh]".

A suggestion for the problem is a complaint about a missing parameter in iwlagn:

dmesg is complaining about:

  iwlagn: Unknown parameter `11n_disable50'

while /etc/modprobe.d/iwlwifi.conf says:

  options iwlagn 11n_disable50=1 11n_disable=1


$ modinfo iwlagn | grep parm
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking (int)
parm:           no_sleep_autoadjust:don't automatically adjust sleep level according to maximum network latency (bool)
parm:           bt_coex_active:enable wifi/bluetooth co-exist (bool)
parm:           debug:debug output mask (uint)
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality (int)
parm:           amsdu_size_8K:enable 8K amsdu size (int)
parm:           fw_restart:restart firmware in case of error (int)
parm:           ucode_alternative:specify ucode alternative to use from ucode file (int)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           bt_ch_inhibition:Disable BT channel inhibition (default: enable) (bool)
parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
parm:           ack_check:Check ack health (default: 0 [disabled]) (bool)

This was just something I found out by following the examples in http://forums.opensuse.org/english/get-technical-help-here/wireless/448350-no-wifi-after-kernel-update.html, so it might not be the problem.

Comment 1 Joakim Hovlandsvåg 2011-08-09 18:22:44 UTC
Created attachment 517459 [details]
What dmesg is saying (if of any help)

Comment 2 John W. Linville 2011-08-09 19:19:35 UTC
Edit /etc/modprobe.d/iwlwifi.conf and make it look like this:

   options iwlagn 11n_disable=1

You might just remove that file instead, if 802.11n support is working OK for you now.

As far as I know, /etc/modprobe.d/iwlwifi.conf is not a file from a Fedora package.  Use 'rpm -qf /etc/modprobe.d/iwlwifi.conf' to see if I am wrong about that.

I'm going to close that on the assumption that the above resolves the issue for you.


Note You need to log in before you can comment on or make changes to this bug.