Bug 729449 - /usr/bin/checkstyle fails to run
Summary: /usr/bin/checkstyle fails to run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: checkstyle
Version: 15
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 18:58 UTC by Omair Majid
Modified: 2011-08-26 19:13 UTC (History)
2 users (show)

Fixed In Version: checkstyle-5.3-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-26 19:13:00 UTC


Attachments (Terms of Use)
patch (680 bytes, text/x-csrc)
2011-08-09 18:58 UTC, Omair Majid
no flags Details

Description Omair Majid 2011-08-09 18:58:09 UTC
Created attachment 517466 [details]
patch

Description of problem:
/usr/bin/checkstyle passes several jakarta-* jar names to the build-classpath script, none of which can be found.

How reproducible:
Every time

Steps to Reproduce:
1. install checkstyle
2. /usr/bin/checkstyle
  
Actual results:
/usr/bin/build-classpath: error: Could not find jakarta-commons-beanutils.jar Java extension for this JVM
/usr/bin/build-classpath: error: Could not find jakarta-commons-cli.jar Java extension for this JVM
/usr/bin/build-classpath: error: Could not find jakarta-commons-logging.jar Java extension for this JVM
/usr/bin/build-classpath: error: Could not find jakarta-commons-collections.jar Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/cli/ParseException
Caused by: java.lang.ClassNotFoundException: org.apache.commons.cli.ParseException
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: com.puppycrawl.tools.checkstyle.Main. Program will exit.


Expected results:
Must specify a config XML file.
usage: java com.puppycrawl.tools.checkstyle.Main [options] -c <config.xml>
            file...
 -c <arg>   The check configuration file to use.
 -f <arg>   Sets the output format. (plain|xml). Defaults to plain
 -o <arg>   Sets the output file. Defaults to stdout
 -p <arg>   Loads the properties file
 -r <arg>   Traverse the directory for source files

Comment 1 Fedora Update System 2011-08-15 08:03:36 UTC
checkstyle-5.3-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/checkstyle-5.3-4.fc15

Comment 2 Fedora Update System 2011-08-17 01:11:04 UTC
Package checkstyle-5.3-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing checkstyle-5.3-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/checkstyle-5.3-4.fc15
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-08-26 19:12:55 UTC
checkstyle-5.3-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.