Bug 729487 - Freemind doesn't escape > properly
Summary: Freemind doesn't escape > properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freemind
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 21:35 UTC by Penelope Fudd
Modified: 2011-09-09 17:00 UTC (History)
2 users (show)

Fixed In Version: freemind-0.9.0-7.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 05:24:51 UTC


Attachments (Terms of Use)
Minimal example of at least partially un-editable node (536 bytes, text/x-troff-mm)
2011-08-12 18:39 UTC, Penelope Fudd
no flags Details
screenshot of long node window, with tiny save button (14.25 KB, image/gif)
2011-08-15 16:30 UTC, Penelope Fudd
no flags Details
Should set default theme to gtk (1.38 KB, text/plain)
2011-08-22 15:23 UTC, Stanislav Ochotnicky
no flags Details

Description Penelope Fudd 2011-08-09 21:35:26 UTC
Description of problem:
I put a short shell script into a long note, and the note broke into two notes.

Version-Release number of selected component (if applicable):
freemind-0.9.0-3.fc14.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a mind map
2. Start a long node
3. Paste in the following text:
foreach n (*.hits)
  gawk '{print $3}' $n > $n.hits.list
  fgrep -w -f $n.hits.list hitlist.txt > $n.genomes.list 
end

  
Actual results:
Two nodes, with the first one ending just before the final '>'.

Expected results:
One node under god, with liberty and justice for all.

Additional info:
Trying to create a minimal example was hard, as some of my tests resulted in read-only nodes or other strangeness.

Comment 1 Penelope Fudd 2011-08-09 21:36:45 UTC
Oh, and I select 'allow bold and italics' in the long node when editing.

Comment 2 hannes 2011-08-12 18:18:21 UTC
Hello,

I really tried to reproduce this bug and also asked others to try it. But I couldn't see any of this. I don't have a f14 installation handy so I am not sure what's at fault here.
Did you paste this into the Long Node Editor (SimplyHtml) or did you just paste i into a regular node which then expanded to a long node?


Johannes

Comment 3 Penelope Fudd 2011-08-12 18:37:43 UTC
I pasted it into the long node editor.

For ease of testing, I'm attaching a minimal example file.  I just deleted all the nodes I could, and kept trying to add '> test' to the end of the problem node by right-clicking and selecting 'edit long node...'.  Every type I clicked on 'save' it closed the edit window but failed to change the node's text.

Comment 4 Penelope Fudd 2011-08-12 18:39:59 UTC
Created attachment 518089 [details]
Minimal example of at least partially un-editable node

Try adding ' > testfile' to the end of the node's text.  If it can't be added when you hit 'save' in the long node editor, the bug is present.

Comment 5 Penelope Fudd 2011-08-12 18:40:21 UTC
Actually, even trying to add 'asdf' (no >) fails.

Comment 6 hannes 2011-08-15 05:56:29 UTC
Just filed an upstream bug report.
https://sourceforge.net/tracker/?func=detail&aid=3391715&group_id=7118&atid=107118
Hope they could shed some light on your problem. 
You installed it via yum? Since I don't have any 'Save' button in the Long Text Editor.

Comment 7 Penelope Fudd 2011-08-15 16:27:20 UTC
I installed it via yum.  I had similar problem with the 'Save' button; it's there, but the text inside the button was shortened to "S...', possibly due to scaling issues.  I don't know why it would be scaled; I'm using a 21" monitor!

Screenshot attached.

Comment 8 Penelope Fudd 2011-08-15 16:30:27 UTC
Created attachment 518287 [details]
screenshot of long node window, with tiny save button

Aha.  'S...' isn't save, which would explain why my changes aren't being saved.  However, the initial problem was that a normal bash command line got split into two nodes.

Comment 9 Penelope Fudd 2011-08-15 16:31:09 UTC
The left-hand button, left of 'Cancel', is the save button.  It only says "...".

Comment 10 hannes 2011-08-16 15:16:11 UTC
Ok, I think this bug is caused by the usage of the "Save" button which is basically the "Split" button. The split button splits the node on the current position of the cursor, that's probably the reason why it was so hard to reproduce also for you.
What's really weird is that you don't see the whole buttons with their respective name. 
Could you perhaps try different Gnome and Java Swing themes? Perhaps try to change the gnome theme first and then have a look at the Java one.

The theme of freemind could be set via "Tools --> Preferences --> Appearance --> Look&Feel". Perhaps try it with "Default".

Comment 11 Penelope Fudd 2011-08-19 18:29:17 UTC
It was set to "Default".  I tried "Nothing", and the buttons now appear correctly.  Same for "Windows".  I haven't tried every theme, but only "Default" cuts off the button text so far.

Comment 12 hannes 2011-08-22 05:36:47 UTC
I think for a nice integration into your gtk/Gnome Desktop, you should try setting it to 'GTK+'. So the Java UI will be drawn with gtk-widgets.
Also I would like to know if the initial 'bug' is solved.

Comment 13 Penelope Fudd 2011-08-22 06:09:02 UTC
I believe it is solved, yes, thank you.  

The next question is, can you change the default in the rpm in the Fedora repository?  Is it already fixed in Fedora15, and if so, can it be backported to Fedora14, which is still a supported release?

Thanks!

Comment 14 Stanislav Ochotnicky 2011-08-22 15:21:48 UTC
I created a test build that should fix the issue, but I don't have F14 to test. 

Koji build is here(unsigned scratchbuild, so only use if you feel adventurous and want to test before real maintainer has a look):
http://koji.fedoraproject.org/koji/taskinfo?taskID=3291778

Comment 15 Stanislav Ochotnicky 2011-08-22 15:23:16 UTC
Created attachment 519305 [details]
Should set default theme to gtk

This patch should fix the issue. To properly test this an F14 with cleaned ~/.freemind directory will be needed.

Comment 16 Fedora Update System 2011-08-23 09:34:28 UTC
freemind-0.9.0-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/freemind-0.9.0-4.fc14

Comment 17 Fedora Update System 2011-08-23 09:34:35 UTC
freemind-0.9.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/freemind-0.9.0-5.fc15

Comment 18 Fedora Update System 2011-08-23 18:50:30 UTC
Package freemind-0.9.0-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freemind-0.9.0-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/freemind-0.9.0-5.fc15
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2011-08-24 19:58:17 UTC
freemind-0.9.0-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freemind-0.9.0-6.fc16

Comment 20 Fedora Update System 2011-08-30 07:11:52 UTC
freemind-0.9.0-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freemind-0.9.0-7.fc16

Comment 21 Fedora Update System 2011-09-02 05:24:46 UTC
freemind-0.9.0-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2011-09-02 05:30:23 UTC
freemind-0.9.0-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-09-09 17:00:13 UTC
freemind-0.9.0-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.