Bug 72949 - /etc/rc.d/init.d/halt kills itself during shutdown sequence, thus hanging the machine
/etc/rc.d/init.d/halt kills itself during shutdown sequence, thus hanging the...
Status: CLOSED DUPLICATE of bug 72043
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-08-29 08:46 EDT by Iustin Pop
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-29 08:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Iustin Pop 2002-08-29 08:46:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
With initscripts-6.91-1 and bash-2.05b-5 and /usr on a separate partition, the
/etc/rc.d/init.d/halt script tries to umount /usr, which cannot be unmounted
because the bash which executes the halt uses the files:
The next step in halt is to call:
    fuser -k -m /usr >/dev/null
but this kills also the bash that is driving halt, so all processes except init
are killed. Now init says 'No more processes left in this runlevel' and the
machine just sits there.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. have a rawhide with /usr on a separate partition
2. have locale 'en_US.UTF-8'
3. try to reboot or shutdown

Actual Results:  hangs as described

Expected Results:  shut down or halt

Additional info:

eliminating the 'fuser -k -m $signal $remaining' will just give a few warnings
and delays but the machine will shutdown ok.
Comment 1 Bill Nottingham 2002-08-29 14:34:38 EDT

*** This bug has been marked as a duplicate of 72043 ***

Note You need to log in before you can comment on or make changes to this bug.