This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 729510 - etracer (and others) do not render properly on sandybridge
etracer (and others) do not render properly on sandybridge
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
[cat:rendering]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 21:01 EDT by Linus Torvalds
Modified: 2011-08-11 11:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-10 17:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2011-08-09 21:01:02 EDT
Description of problem:

 As everybody knows, the true test of any 3D acceleration is how well it runs TuxRacer, that kind of games. Some people talk about portal, others rave over the graphics requirements of Crysis, but all true men know that TuxRacer is the ultimate in gaming enjoyment.

The only thing that can beat TuxRacer is the even more awesome Extreme Tux Racer, installed by default (and if not, it damn well should be!) as

     extremetuxracer-0.4-6.fc15.x86_64

so that you can waste whole minutes watching that stupid penguin slide down the icy stretches of the game world.

However, typing "etracer" on a modern sandybridge laptop leads to disappointment and gnashing of teeth. The game startup is promosing, but as the excitement mounts, and the penguin starts speeding downhill, the game quickly (usually within a few tens of seconds) will degenerate into a random flickering of triangles.


Version-Release number of selected component (if applicable):

The mesa version claims to be:

   mesa-libGL-7.11-0.16.20110709.0.fc15.x86_64

but I suspect it of lying. As far as I can tell, Mesa-7.11 was released just a week ago (July 31), but that mesa-libGL-7.11 package is much older than that. The packages are dated from early June. 

So clearly it's not the real mesa-7.11, but some fake development version.
 
How reproducible:

Very. I haven't ever been able to finish a race. And I'm a *master* at that game. I will take on all on-comers.

Steps to Reproduce:
1. Get a fancy Sandybridge machine (eg Lenovo X11)
2. Install Fedora 15 on it, and the extremetuxracer package
3. Run "etracer"
  
Actual results:

Tens of seconds of glorious gameplay, followed by an unholy mess of incorrect triangles and a series of errors from drm:

   [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 135123 at 135115, next 135124)
   [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung

with the resulting disappointment in gaming experience.

NOTE: Apparently the same failure can be seen in bzflag, the multiplayer tank game. But as that one doesn't involve penguins sliding down an icy surface, I have never played it myself. 

Expected results:

 Glorious, glorious penguin action. Herrings. All in high-speed 3D.

Additional info:

I brought this showstopper bug to the attention of Keith Packard at the recent Intel Tech Days middle of July. He had a fix for it - I saw the game working on his laptop - and swore that it would be in the 7.11 release.

But since Fedora doesn't actually ship the *released* 7.11, but some older version that predates the fix, I cannot get my sliding penguin.

Btw, it's not just TuxRacer and bzflags. 3D acceleration is badly broken on sandybridge, and F15 really seriously needs the fixes from Mesa-7.11. Nothing really works.
Comment 1 Linus Torvalds 2011-08-09 21:05:38 EDT
I cannot type.

"that kind of games" should be "that KING of games"

And "Lenovo X11" is "Lenovo X1".

"promosing" is also a very odd spelling of the word "promising".

I can only blame excessive gnashing of teeth for these errors. But the gist of the bug report is hopefully clear despite the occasional confusing typo.
Comment 2 Linus Torvalds 2011-08-10 17:44:58 EDT
I did a yum update today, and got an updated Mesa package. 

And what do you know? It seems to be the real 7.11 Mesa release, and fixes the Tux Racer problem as expected (along with . So I'm closing the bug.
Comment 3 Matěj Cepl 2011-08-11 11:08:30 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.