Bug 729526 - Kernel Panic after upgrade to 2.6.40 (Linux 3.0)
Summary: Kernel Panic after upgrade to 2.6.40 (Linux 3.0)
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 03:58 UTC by Doug Enright
Modified: 2011-08-11 14:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 14:34:35 UTC


Attachments (Terms of Use)

Description Doug Enright 2011-08-10 03:58:52 UTC
Description of problem:

I recently performed a yum update to update my notebook system (Sandy Bridge-based) to 2.6.40 (Linux 3.0). The yum update appeared to run just fine, but upon rebooting I receive the following error message:

/bin/sh: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory
[    5.229739] Kernel panic - not syncing: Attempted to kill init!
[    5.229806] Pid: 1, comm: init Not tainted 2.6.40-4.fc15.x86_64 #1
... call trace ...

I've never seen such a message before and it's quite disconcerting! I am able to boot into the kernel I upgraded from and have determined that the symbolic link libgcc_s.so.1 exists in bot /lib and /lib64 and points to non-zero libgcc shared libraries.

Given I am able to boot into the older kernel and the shared object files exist, I am perplexed about what is going on.

I also tried to boot with the 2.6.40 debug kernel and the system just hung. I believe the system hung further into the boot process and I did not see this error message.

Version-Release number of selected component (if applicable):

Fedora 15 (Lovelock)

How reproducible:

Completely reproducible.  Happens every time I attempt to boot using this kernel.

Steps to Reproduce:
1. Select kernel 2.6.40 in grub and being boot process.
2.
3.
  
Actual results:

See above.

Expected results:

A properly booted system.  I do not observe this problem on my Core i7-930 desktop system, also running Fedora 15 64-bit.

Additional info:

Comment 1 Josh Boyer 2011-08-10 11:54:16 UTC
(In reply to comment #0)
> Description of problem:
> 
> I recently performed a yum update to update my notebook system (Sandy
> Bridge-based) to 2.6.40 (Linux 3.0). The yum update appeared to run just fine,
> but upon rebooting I receive the following error message:
> 
> /bin/sh: error while loading shared libraries: libgcc_s.so.1: cannot open
> shared object file: No such file or directory
> [    5.229739] Kernel panic - not syncing: Attempted to kill init!
> [    5.229806] Pid: 1, comm: init Not tainted 2.6.40-4.fc15.x86_64 #1
> ... call trace ...
> 
> I've never seen such a message before and it's quite disconcerting! I am able
> to boot into the kernel I upgraded from and have determined that the symbolic
> link libgcc_s.so.1 exists in bot /lib and /lib64 and points to non-zero libgcc
> shared libraries.

The kernel doesn't use shared libraries.  This might be a problem with the initramfs that is being used to boot the 2.6.40 kernel.  Try booting with the older kernel (which will use it's own initramfs), yum removing and yum installing the 2.6.40 kernel again.  (Or if you know how to rebuild the initramfs by hand, give that a go).

Comment 2 Doug Enright 2011-08-10 14:34:35 UTC
Hi Josh,

Thanks for the assistance.  

I was able to successfully uninstall and then reinstall the kernel-2.6.40-4.fc15 package.

After doing so, I rebooted the system and it was able to fully complete the boot process and start the windows manager to allow me to log in.

Thanks again for your help!

Doug

PS I'm happy to upload the output /var/log/messages from my latest successful if folks would find that helpful.

Comment 3 Eddie Lania 2011-08-11 13:46:21 UTC
Well, it doesn't work for me.

Maybe it's not working for me because I use some older hardware?
I have a regular 3.0 GHz Intel Pentium 4 processor on a Intel D865GLC mainboard.

I erased and reinstalled this kernel twice but i still get kernel panics during boot.
I also used yumdownloader to download the kernel rpm amd did a "yum localinstall" but it doesn't help either.

the older kernels boot fine.

So, I really would like this bug to be reopened again.

Comment 4 Josh Boyer 2011-08-11 13:57:51 UTC
(In reply to comment #3)
> Well, it doesn't work for me.
> 
> Maybe it's not working for me because I use some older hardware?
> I have a regular 3.0 GHz Intel Pentium 4 processor on a Intel D865GLC
> mainboard.
> 
> I erased and reinstalled this kernel twice but i still get kernel panics during
> boot.
> I also used yumdownloader to download the kernel rpm amd did a "yum
> localinstall" but it doesn't help either.
> 
> the older kernels boot fine.
> 
> So, I really would like this bug to be reopened again.

"Gets panics during boot" doesn't really tell us anything.  Please open a new bug and attached the panic output.

Comment 5 Doug Enright 2011-08-11 14:00:42 UTC
I would agree with Josh and recommend filing a new bug report since your situation is different from mine.  I have had no problems booting since reinstalling the kernel.

It's not hard to establish a bugzilla account and file a bug report.

Comment 6 Eddie Lania 2011-08-11 14:17:06 UTC
Bug #730007 created. And of course I already have a bugzilla account else i wouldn't have been able to post replies here.

Comment 7 Doug Enright 2011-08-11 14:19:57 UTC
Yes, I realized that after I made my post ... it's early morning where I am.


Note You need to log in before you can comment on or make changes to this bug.