Bug 729538 - kernel-3.0.1-3.fc16.i686 boot process waits for about 20 sec before it starts
Summary: kernel-3.0.1-3.fc16.i686 boot process waits for about 20 sec before it starts
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 06:05 UTC by sd.domrep
Modified: 2011-08-22 08:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 11:34:10 UTC


Attachments (Terms of Use)
dmesg-kernel-3.0.1-2.txt (49.38 KB, text/plain)
2011-08-10 13:46 UTC, sd.domrep
no flags Details
dmesg-kernel-3.0.1-3.txt (49.55 KB, text/plain)
2011-08-10 13:47 UTC, sd.domrep
no flags Details
lspci.txt (1.94 KB, text/plain)
2011-08-10 13:48 UTC, sd.domrep
no flags Details
boot video 22 sec (2.95 MB, video/x-msvideo)
2011-08-12 06:53 UTC, sd.domrep
no flags Details

Description sd.domrep 2011-08-10 06:05:03 UTC
Description of problem:
The problem is - with kernel-3.0.1-3.fc16.i686 there is a halt for about 20 sec before it starts to boot everything.
I see just black screen for ~ 20 sec.

Kernel-3.0.1-2.fc16 starts to boot without any delays. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Josh Boyer 2011-08-10 11:45:11 UTC
Can you attach /var/log/messages from both 3.0.1-2.fc16 and 3.0.1-3.fc16?

What kind of machine?

The only difference between those two kernels is a small utrace update.

Comment 2 sd.domrep 2011-08-10 13:45:24 UTC
No problem.
I want to say again that this halt occurs before I see "Probing EDD ..." on my screen.
This is laptop Lenovo 3000 C100

I attached dmesges and "lspci"

Thanks.

Comment 3 sd.domrep 2011-08-10 13:46:25 UTC
Created attachment 517609 [details]
dmesg-kernel-3.0.1-2.txt

Comment 4 sd.domrep 2011-08-10 13:47:31 UTC
Created attachment 517610 [details]
dmesg-kernel-3.0.1-3.txt

Comment 5 sd.domrep 2011-08-10 13:48:38 UTC
Created attachment 517611 [details]
lspci.txt

Comment 6 sd.domrep 2011-08-11 13:00:16 UTC
kernel-3.0.1-5.fc16 - there is no difference, the same ~ 20 sec delay before boot starts.

Thanks.

Comment 7 Josh Boyer 2011-08-11 13:49:25 UTC
You seem to have i915.i915_enable_fbc=1 set on your kernel command line for 3.0.1-3.  Could you try removing that and seeing if the behavior matches 3.0.1-2?

I don't see much else that is different in the boot output from the attached dmesgs.  It seems both boots progress at approximately the same speed, so perhaps the console device simply isn't being updated.

Comment 8 sd.domrep 2011-08-11 15:14:01 UTC
It does nothing to kernel - it is for i915 driver.
And I removed it in kernel-3.0.1-5.fc16 anyway.
You wont see anything in dmesg, because the 20 sec pause occur before any logging starts.
This halt occurs before I see "Probing EDD ..." on my screen. Immediately after I choose which kernel to boot through grub.
Later I can take short video if one do not believe me.

Comment 9 Josh Boyer 2011-08-11 18:37:11 UTC
(In reply to comment #8)
> It does nothing to kernel - it is for i915 driver.
> And I removed it in kernel-3.0.1-5.fc16 anyway.
> You wont see anything in dmesg, because the 20 sec pause occur before any
> logging starts.
> This halt occurs before I see "Probing EDD ..." on my screen. Immediately after
> I choose which kernel to boot through grub.
> Later I can take short video if one do not believe me.

Sorry, I missed the "before Probing EDD" part.  That's called extremely early in the boot, and there isn't much before it.  Adding 'debug' to the kernel command line might help show if it's hung even before we get to validating the CPU or not, but that is going to be of somewhat limited value.

Comment 10 sd.domrep 2011-08-12 06:49:21 UTC
Ok, I took short (for 22 sec) video, there is no much to see, sorry.
At the end of the halt period with "debug" there is only one new line appears:
"early console in setup code".

Comment 11 sd.domrep 2011-08-12 06:53:58 UTC
Created attachment 517969 [details]
boot video 22 sec

Comment 12 Josh Boyer 2011-08-12 12:39:28 UTC
(In reply to comment #10)
> Ok, I took short (for 22 sec) video, there is no much to see, sorry.
> At the end of the halt period with "debug" there is only one new line appears:
> "early console in setup code".

OK, that means it's likely either the bootloader or the firmware are adding the additional delay.  There are basically only a handful of lines of assembly code that are run before that "early console in setup code" is printed.

Comment 13 sd.domrep 2011-08-13 07:47:41 UTC
Good news.

In the last few updates there was anaconda-16.14.4-1.fc16 and dracut-013-1.fc16 update.
I did those updates and then reinstalled the latest kernel from koji - kernel-3.0.1-5.fc16.
And there is no halts any more - problem solved.

Thanks.

Comment 14 Josh Boyer 2011-08-15 11:34:10 UTC
Glad to hear it.

Comment 15 Harald Hoyer 2011-08-22 08:58:28 UTC
(In reply to comment #3)
> Created attachment 517609 [details]
> dmesg-kernel-3.0.1-2.txt

[    5.936077] dracut: dracut-011-15.git20110720

Comment 16 Harald Hoyer 2011-08-22 08:59:14 UTC
(In reply to comment #4)
> Created attachment 517610 [details]
> dmesg-kernel-3.0.1-3.txt

[    5.937923] dracut: dracut-011-15.git20110720


Note You need to log in before you can comment on or make changes to this bug.