Bug 72954 - "Offline files" in Windows 2000 can't authenticate when offline
"Offline files" in Windows 2000 can't authenticate when offline
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 09:59 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 10:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-29 09:59:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818)

Description of problem:
After upgrading our server to Redhat 7.3 from Redhat 7.2 the ability to 
syncronize "Offline files" in Windows 2000 ceased to work. When unplugging the 
network the files are now either unavailable (non visible) or non-readable. 
Authentication is done through a Windows NT PDC with security = domain. If the 
file is world r/w then synchronization is possible. If you bring up 
the "Offline files folder" you can see that you have no access to the files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up samba server with security = domain and NOT as PDC (haven't tried 
this)
2. Create a few files and deny access to other users than yourself and your 
group.
3. On windows 2000 client, mark the files and select "Make available offline".
4. Go offline or kill the samba service.
5. Try to open the files


Actual Results:  File access is denied.

Expected Results:  Should have been able to modify the files offline for later 
synchronization.

Additional info:

Tried installing samba-2.2.5-1.i386.rpm from the samba team and this behaviour 
disappears. It is also fixed with the samba packages from 
http://people.redhat.com/teg/samba/.
Comment 1 Trond Eivind Glomsrxd 2002-08-30 12:22:39 EDT
The packages you refer to are currently in rawhide (2.2.5-9)

Note You need to log in before you can comment on or make changes to this bug.