Bug 729556 - "Search Projects" search box should be labelled, and possibly moved
"Search Projects" search box should be labelled, and possibly moved
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4.2
  Show dependency treegraph
 
Reported: 2011-08-10 03:15 EDT by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 20:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2011-08-10 03:15:07 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.124 Safari/534.30

At the moment there is a search box for searching for Projects, however it is not labelled, nor is it in a intuitive place.

It should labelled "Search Projects:", otherwise it is not clear what the search box is for, and "Search Projects:" functionality appears to be missing from the UI.

More intuitive places to put the "Search Projects:" box:
* On the Projects tab/page, at the very top, under the tabs/page selectors
* On the Projects tab/page, under the Actions Box.


Reproducible: Always
Comment 1 Sean Flanigan 2011-08-10 20:31:15 EDT
* On the Projects tab/page, at the very top, under the tabs/page selectors

I think we should move it there, and change the button name to Search Projects.
Comment 2 Sean Flanigan 2011-09-07 00:33:25 EDT
Assigning to Scrum product owner for prioritisation.
Comment 4 Ding-Yi Chen 2011-10-20 22:09:25 EDT
VERIFIED with Zanata version 1.4.2-SNAPSHOT (20111021-1030)
Comment 5 Ding-Yi Chen 2011-10-20 22:22:46 EDT
Um, sorry, just find some new bugs that might related to this bug.

On Zanata version 1.4.2-SNAPSHOT (20111021-1030), test server zanata-esperance (1.4-nukes),

Searching on "about" should find at least following projects:
  Whats This About
  About Fedora (python)
  About Fedora

However, the server actually returns:
 testMvn
 Whats This About
 About Fedora (python)

testMvn does not have "about" in project id, name, and description.

Thus this bug should be REASSIGNED.
Comment 6 Ding-Yi Chen 2011-10-21 00:32:10 EDT
The problem seems gone after reindexed the database. Thus this bug should be considered as VERIFIED
Comment 7 Sean Flanigan 2011-10-21 00:32:39 EDT
This appears to have been caused by stale Hibernate Search indexes on that machine, probably when I imported the test data from another machine.  

I re-indexed the full-text-search database, and the project search feature appears to be working.

Note You need to log in before you can comment on or make changes to this bug.