Bug 72956 - can't print to pdf from oo writer
can't print to pdf from oo writer
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: openoffice.org (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 10:11 EDT by Marius Andreiana
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-04 06:58:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2002-08-29 10:11:41 EDT
The pdf file printed from oo writer can't be opened by xpdf or acroread (
doesn't start with PDF ).
Comment 1 Jakub Jelinek 2002-08-30 09:26:03 EDT
How have you printed to PDF? Have you run OpenOffice.org Printer Admin and
chose a PDF converter there?
In the next rpm I'll add PDF converter as a printer option by default, so that
one doesn't have to go to oopadmin for that, but no matter what, you have
to select the PDF converter as your printer to print to PDF.
Comment 2 Marius Andreiana 2002-08-30 09:42:21 EDT
First I printed from OO writer without going to Printer Admin ( the separate
menu item in Office menu ). I chosed PDF, selected name of the file and so on.
It didn't warn me about Printer Admin.

After that I went to the Printer Admin and defined the default as PDF. About PDF
converter, you mean the /usr/bin/gs with lots of paramenters line? It was there,
I didn't changed it, just checked that /usr/bin/gs is installed. After this I
tried again in OO writer, still didn't worked. 

Maybe I'm missing something? Let me know if it works for you or if I should get
the most recent package from rawhide and I'll try again. 

Thanks
Comment 3 Alan Cox 2002-12-15 17:48:42 EST
PDF doesnt work for me either
I ended up printing to ps and using ps2pdf
Comment 4 Marius Andreiana 2002-12-27 10:17:07 EST
This still doesn't work in phoebe. Resulting file is actually postscript.

I haven't tried using ooadmin first, as Jakub said "In the next rpm I'll add PDF
converter as a printer option by default, so that one doesn't have to go to
oopadmin for that". This would be much better, as beginners don't know about
ooadmin.
Comment 5 Marius Andreiana 2003-01-12 08:53:56 EST
Printing to PDF works if a PDF printer is setup first.
Comment 6 Marius Andreiana 2003-03-04 06:58:34 EST
works fine with oo 1.0.2 without setting the pdf printer, tested on phoebe3

Note You need to log in before you can comment on or make changes to this bug.