Bug 729575 - "rhncfg-client verify" generates a traceback if sslCACert is not define.
Summary: "rhncfg-client verify" generates a traceback if sslCACert is not define.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2011-08-10 08:46 UTC by Dimitar Yordanov
Modified: 2011-11-24 12:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-24 12:32:29 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2011-08-10 08:46:40 UTC
Description of problem:
"rhncfg-client verify" generates a traceback if sslCACert is not define.
sslCACert can be defined in:
     /etc/sysconfig/rhn/rhncfg-client.conf
     /etc/sysconfig/rhn/up2date

Version-Release number: of selected component (if applicable):
rhncfg-client-5.9.27-17.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. yum install rhncfg*
2. register the Host to xmlrpc.rhn.errata.stage.redhat.com
3. Make sure lines starting with sslCACert in both
     /etc/sysconfig/rhn/rhncfg-client.conf
     /etc/sysconfig/rhn/up2date
   are commented out.
4. rhncfg-client verify
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/rhncfg-client", line 34, in <module>
    sys.exit(Main().main() or 0)
  File "/usr/share/rhn/config_common/rhn_main.py", line 170, in main
    repo = getattr(repo_module, self.repository_class_name)()
  File "/usr/share/rhn/config_client/rpc_cli_repository.py", line 32, in __init__
    repository.RPC_Repository.__init__(self, setup_network)
  File "/usr/share/rhn/config_common/repository.py", line 257, in __init__
    ca = self._local_config.get('sslCACert')
  File "/usr/share/rhn/config_common/local_config.py", line 102, in get
    return _get_config().get_option(var)
  File "/usr/share/rhn/config_common/local_config.py", line 69, in get_option
    ret = self.get(self.section, option, vars=self.overrides)
  File "/usr/lib64/python2.6/ConfigParser.py", line 546, in get
    return self._interpolate(section, option, value, d)
  File "/usr/lib64/python2.6/ConfigParser.py", line 586, in _interpolate
    if "%(" in value:
TypeError: argument of type 'NoneType' is not iterable


Expected results:
Some reasonable error/info message as it is if the Certificate can not be found/does not exist.
Can not find CA file: /usr/share/rhn/RHNS-CA-CERT_foo
Additional info:

Comment 1 Jan Pazdziora 2011-11-24 12:32:29 UTC
I was not able to reproduce this issue on RHEL 6.2:

# grep serverURL /etc/sysconfig/rhn/rhncfg-client.conf /etc/sysconfig/rhn/up2date
/etc/sysconfig/rhn/up2date:disallowConfChanges=noReboot;sslCACert;useNoSSLForPackages;noSSLServerURL;serverURL;disallowConfChanges;
/etc/sysconfig/rhn/up2date:serverURL[comment]=Remote server URL
/etc/sysconfig/rhn/up2date:serverURL=https://xmlrpc.rhn.errata.stage.redhat.com/XMLRPC
# grep sslCA /etc/sysconfig/rhn/rhncfg-client.conf /etc/sysconfig/rhn/up2date
/etc/sysconfig/rhn/rhncfg-client.conf:# sslCACert = /usr/share/rhn/RHNS-CA-CERT
/etc/sysconfig/rhn/up2date:disallowConfChanges=noReboot;sslCACert;useNoSSLForPackages;noSSLServerURL;serverURL;disallowConfChanges;
/etc/sysconfig/rhn/up2date:# sslCACert[comment]=The CA cert used to verify the ssl server
/etc/sysconfig/rhn/up2date:# sslCACert=/usr/share/rhn/RHNS-CA-CERT
# rhncfg-client verify
#

# rpm -qa | grep rhn | sort
rhncfg-5.9.27-18.el6.noarch
rhncfg-actions-5.9.27-18.el6.noarch
rhncfg-client-5.9.27-18.el6.noarch
rhncfg-management-5.9.27-18.el6.noarch
rhn-check-1.0.0-73.el6.noarch
rhn-client-tools-1.0.0-73.el6.noarch
rhnlib-2.5.22-12.el6.noarch
rhnsd-4.9.3-2.el6.i686
rhn-setup-1.0.0-73.el6.noarch
yum-rhn-plugin-0.9.1-36.el6.noarch
#

All the /usr/share/rhn paths in the traceback are from rhncfg* packages, so the component should not be rhn-client-tools. Thus, clearing the RHEL-related flags, changing product.

Closing as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.