Bug 729652 - PNP0A08: host bridge window [mem 0x000cc000-0x000cffff] conflicts with Video ROM [mem 0x000c0000-0x000cedff
Summary: PNP0A08: host bridge window [mem 0x000cc000-0x000cffff] conflicts with Video ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 706606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 13:23 UTC by Jóhann B. Guðmundsson
Modified: 2011-09-07 00:00 UTC (History)
10 users (show)

Fixed In Version: 3.1.0-0.rc3.git0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-01 06:50:06 UTC


Attachments (Terms of Use)
Dmesg (70.98 KB, text/plain)
2011-08-10 13:23 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-08-10 13:23:38 UTC
Created attachment 517597 [details]
Dmesg

Description of problem:

[    0.445252] pci_root PNP0A08:00: address space collision: host bridge window [mem 0x000cc000-0x000cffff] conflicts with Video ROM [mem 0x000c0000-0x000cedff

Do see display glitches ( fonts weird not all icons showing unless I move the mouse pointer to the missing side then they appear etc.. ) but that could be Gnome-shell or the Xorg driver.

The card is. 

01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200] 


Version-Release number of selected component (if applicable):

3.0.1-3.fc16.x86_64

How reproducible:
 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chuck Ebbert 2011-08-10 19:29:32 UTC
Did this just start happening with a recent kernel or has it been happening on older releases too?

Comment 2 Bjorn Helgaas 2011-08-10 19:41:28 UTC
You can just ignore that message; it's not telling us anything useful.

Upstream commit 43d786ed4df4c54cb8802a523748a7d78130a2cb should resolve this (it only downgrades the message from KERN_ERR to KERN_INFO).

I'm pretty sure the display glitches are unrelated to this message.  You could boot with "pci=nocrs", which will turn off the code that pays attention to the host bridge windows, and should make the message go away.  I don't think "pci=nocrs" will make any difference as far as the glitches.  If it *does* make a difference, then they're related and we need to investigate more.

Comment 3 Jóhann B. Guðmundsson 2011-08-10 19:53:11 UTC
(In reply to comment #1)
> Did this just start happening with a recent kernel or has it been happening on
> older releases too?

This started to appear with 3.0.0 

I'll test with older kernels tonight

Comment 4 Jóhann B. Guðmundsson 2011-08-10 19:54:20 UTC
(In reply to comment #2)
> You can just ignore that message; it's not telling us anything useful.
> 
> Upstream commit 43d786ed4df4c54cb8802a523748a7d78130a2cb should resolve this
> (it only downgrades the message from KERN_ERR to KERN_INFO).
> 
> I'm pretty sure the display glitches are unrelated to this message.  You could
> boot with "pci=nocrs", which will turn off the code that pays attention to the
> host bridge windows, and should make the message go away.  I don't think
> "pci=nocrs" will make any difference as far as the glitches.  If it *does* make
> a difference, then they're related and we need to investigate more.

From the test list others are seeing clitches hence this seems to be radeon/clutter/gnome-shell not the kernel that causes that.

Comment 5 Chuck Ebbert 2011-08-26 00:08:40 UTC
This keeps getting reported, so I've included the patch from 3.1 to reduce the severity of the warning.

Comment 6 Chuck Ebbert 2011-08-26 04:01:53 UTC
*** Bug 706606 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-09-01 11:06:47 UTC
kernel-2.6.40.4-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.4-5.fc15

Comment 8 collura 2011-09-02 23:23:55 UTC
yes this warning disappeared when upgraded to kernel-2.6.40.4-5.fc15 (x86_64) 

thanks

Comment 9 Fedora Update System 2011-09-07 00:00:56 UTC
kernel-2.6.40.4-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.