Bug 72969 - PCMCIA should be started before NETWORK
PCMCIA should be started before NETWORK
Status: CLOSED DUPLICATE of bug 125250
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 12:02 EDT by Ed Halley
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Halley 2002-08-29 12:02:49 EDT
Description of Problem:
  In versions 7.0 and 7.1 of RHL, the network was started after the pcmcia
  card manager.  This causes problems on many laptop pcmcia-based ethernet
  cards.

  In versions 7.2 and 7.3 of RHL, the problems were fixed for my Toshiba
  laptop, but I still heard anecdotal reports that it was not fixed for
  everyone.

  In the null beta of RHL, the situation regressed, and my Toshiba laptop
  again cannot find network unless I manually restart pcmcia and network,
  or change the initscripts to start the pcmcia service first.

  for i in 2 3 4 5 ; do
     mv /etc/rc.d/rc$i.d/S*pcmcia /etc/rc.d/rc$i.d/S09pcmcia
  done

Additional Information:

  Starting pcmcia services earlier seems to be a reliable fix for many
  different types of pcmcia-based ethernet adapters, and does not seem to
  have any downside from other ordering dependencies.
	
  If there's any possible reason why the S*pcmcia scripts should not be
  moved to S09pcmcia to start before S10network, could they please
  document it clearly here.

  This is only for boot time, and unrelated to pcmcia and network
  problems on suspend, though a similar solution in the apmd wake
  scripts may be effective.
Comment 1 Richard Torkar 2002-08-29 12:12:41 EDT
Have to say that this is not the case for my laptop (DELL L400).
When I come back from suspend mode I have to turn off:

a) network
b) pcmcia
and then turn them on in this order:
a) network
b) pcmcia

(I use a DELL TrueMobile 1150 wlan card)

This pcmcia thingy under Linux in general but red hat specifically will bug me 
to death. Under Gentoo Linux I had no problems what so ever.

/Richard
Comment 2 Bill Nottingham 2004-09-08 03:00:50 EDT

*** This bug has been marked as a duplicate of 125250 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.