Bug 729709 - aeolus-node errors out when given "--help" command line argument
Summary: aeolus-node errors out when given "--help" command line argument
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 0.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Mo Morsi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 15:23 UTC by Justin Clift
Modified: 2015-07-13 04:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 04:06:24 UTC


Attachments (Terms of Use)

Description Justin Clift 2011-08-10 15:23:23 UTC
Description of problem:

  When providing the standard *nix "--help" option to aeolus-node, it errors out:

    $ aeolus-node --help
    /bin/cat: /etc/aeolus-configure/nodes/default_--help: No such file or directory

  It should instead display some form of banner/usage information.

Version-Release number of selected component (if applicable):

  The Aeolus 0.3.0 release rpms: aeolus-configure-2.0.1-1.el6.fc14.noarch

How reproducible:

  Every time.

Comment 1 Mo Morsi 2011-09-22 04:06:24 UTC
aeolus-node is not meant to be invoked by the end user. Rather it serves as a helper script required by puppet to be run by the configuration suite whose purpose is to simply output the specified node yaml.

Thus we cannot display any help / banner text as this would throw puppet off and result in unintended results.

To get around this I moved aeolus-node off the standard user executable PATH and updated references in configure to refer to the exact location on the filesystem. 

This is resolved with the following commit:

http://git.fedorahosted.org/git/?p=aeolus/configure.git;a=commitdiff;h=8e85f17175ccabbdd9a87de83e9757f34d9fda1e


Note You need to log in before you can comment on or make changes to this bug.