Bug 729713 - gnome-session gets killed when it's oom
Summary: gnome-session gets killed when it's oom
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-session
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 15:34 UTC by Aleš Mareček
Modified: 2011-10-24 14:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-21 13:48:54 UTC


Attachments (Terms of Use)

Description Aleš Mareček 2011-08-10 15:34:54 UTC
Description of problem:
gnome session gets killed when system runs out of memory. No warning message is raised just all programs are killed and session is restarted.

Version-Release number of selected component (if applicable):
gnome-session-2.28.0-17.el6

How reproducible:
Few minutes after oom (free memory about 5%)

Steps to Reproduce:
1. run Firefox 5.0 with a few tabs (more is better) OR run another memory eater
2. gnome-session will be restarted without any warning
  
Actual results:
system will freeze for few minutes then running programs will be killed, session will restart.
Log:
[alich@angband ~]$ dmesg | grep gnome-session
Out of memory: kill process 2754 (gnome-session) score 353386 or a child
Out of memory: kill process 2754 (gnome-session) score 341243 or a child
Out of memory: kill process 2754 (gnome-session) score 318305 or a child
Out of memory: kill process 2754 (gnome-session) score 293765 or a child
Out of memory: kill process 2754 (gnome-session) score 279522 or a child
Out of memory: kill process 2754 (gnome-session) score 224367 or a child
Out of memory: kill process 2754 (gnome-session) score 215884 or a child
Out of memory: kill process 2754 (gnome-session) score 208070 or a child
Out of memory: kill process 2754 (gnome-session) score 201137 or a child
Out of memory: kill process 2754 (gnome-session) score 193052 or a child
Out of memory: kill process 2754 (gnome-session) score 192182 or a child
Out of memory: kill process 2754 (gnome-session) score 176468 or a child
Out of memory: kill process 2754 (gnome-session) score 166597 or a child
Out of memory: kill process 2754 (gnome-session) score 135099 or a child
gnome-session invoked oom-killer: gfp_mask=0x201da, order=0, oom_adj=0
gnome-session cpuset=/ mems_allowed=0
Pid: 2754, comm: gnome-session Tainted: G           ---------------- T 2.6.32-169.el6.x86_64 #1
Out of memory: kill process 2754 (gnome-session) score 80745 or a child
Out of memory: kill process 2754 (gnome-session) score 73733 or a child
Out of memory: kill process 2754 (gnome-session) score 61517 or a child
Out of memory: kill process 2754 (gnome-session) score 29461 or a child
Out of memory: kill process 15963 (gnome-session) score 456454 or a child
Out of memory: kill process 15963 (gnome-session) score 438191 or a child
Out of memory: kill process 15963 (gnome-session) score 423777 or a child
Out of memory: kill process 15963 (gnome-session) score 377830 or a child
Out of memory: kill process 15963 (gnome-session) score 347221 or a child
Out of memory: kill process 15963 (gnome-session) score 298338 or a child
Out of memory: kill process 15963 (gnome-session) score 286850 or a child
Out of memory: kill process 15963 (gnome-session) score 276432 or a child
Out of memory: kill process 15963 (gnome-session) score 267189 or a child
Out of memory: kill process 15963 (gnome-session) score 256209 or a child
Out of memory: kill process 15963 (gnome-session) score 255049 or a child
Out of memory: kill process 15963 (gnome-session) score 233821 or a child
Out of memory: kill process 15963 (gnome-session) score 220965 or a child
Out of memory: kill process 15963 (gnome-session) score 150343 or a child
Out of memory: kill process 15963 (gnome-session) score 111259 or a child
Out of memory: kill process 15963 (gnome-session) score 99742 or a child


Expected results:
Warning message, no program is killed

Additional info:
I have 2GB of RAM and about 150MB free when it starts the carnage process.

Comment 1 Ray Strode [halfline] 2011-08-10 17:22:08 UTC
we could fool around with oom_adj or so but that won't solve the problem generally, and so I don't think it's really worth doing.  I think the answer here is:

1) if you're going to run a system with only 2gb of ram, enable swap
2) if you don't want the default kernel behavior of "kill an arbitrary process" then manually set overcommit as appropriate

What are your thoughts?

Comment 2 Aleš Mareček 2011-08-11 08:23:02 UTC
Hi Ray,
My choise is 1. But I'm so surprise because I thought I had a swap on! :O Actually, I don't know how is possible that I haven't it because I would never use the desktop without swap.
Thanks for advice I'll fix it and hope it solve the problem.

Comment 3 Aleš Mareček 2011-08-11 12:13:16 UTC
Well it seems that SWAP was turned on but I have to say it's something strange in there. I use LVM and have 3 root partitions...when I want to test other release "life" I use the old one. At last there is swap on but it seems it's something strange in there - I need some time to investigate it.

Comment 4 Suzanne Yeghiayan 2011-10-06 18:51:24 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.
               
Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 8 Ray Strode [halfline] 2011-10-24 14:06:16 UTC
Aleš, what's the bug number for the firefox issue ?


Note You need to log in before you can comment on or make changes to this bug.