Bug 729728 - Promotions - navigating left pane - click behavior is not consistent
Summary: Promotions - navigating left pane - click behavior is not consistent
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-10 16:32 UTC by Brad Buckingham
Modified: 2019-09-26 13:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:52:04 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2011-08-10 16:32:39 UTC
Description of problem:

While navigating on the promotions page, noticed that clicking elements in the left pane does always trigger the desired action (e.g. go to next element in the breadcrumb or opening of right pane).  

After investigation and discussion with Justin, it appears that the click event is probably not being bound to the entire row/element.  E.g. clicks a few pixels above or below the text are ignored.

Version-Release number of selected component (if applicable):
git master

How reproducible:
always

Steps to Reproduce:
1. go to Content Management -> Promotions
2. click a few pixels above or below an element in the left panel
  
Actual results:
Nothing happens.

This appears to be the behavior regardless of where the user is in the breadcrumb.

Expected results:
left panel goes to next element in the breadcrumb or a right pane is opened.. (expected behavior depends on which element is being clicked)

Additional info:

Comment 1 Eric Helms 2011-08-24 22:31:34 UTC
commit ec1f2b7ee99b606dc228aa517ce8b21491b247dc

This commit should enable clicking anywhere inside a highlighted block on the promotions page and seeing the sliding effect.

Comment 2 Jeff Weiss 2011-09-22 02:42:09 UTC
Verified, katello-0.1.83-1.git.43.0db4170.fc14.noarch

Comment 5 Mike McCune 2013-08-16 18:12:39 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.