Bug 72980 - cindent being ignored from .vimrc
cindent being ignored from .vimrc
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: vim (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 13:32 EDT by Steve Fox
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 07:19:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2002-08-29 13:32:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
I have 'set cindent' in my .vimrc file, but it is no being activated when vim
starts. If I manually tell vim ':set cindent' it will work, but it's annoying to
always have to manually enable this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put 'set cindent' in your .vimrc file
2. Edit some source code and press enter after typing a {

	

Actual Results:  The cursor goes to the beginning of the next line

Expected Results:  The cursor should go to the next line, then indent to one tab
more than the { on the previous line.

Additional info:

auto-indent also enabled

vim-minimal-6.1-14
vim-X11-6.1-14
vim-common-6.1-14
vim-enhanced-6.1-14
Comment 1 Karsten Hopp 2002-11-12 08:09:45 EST
This works for me. 
- Did you start the editor with 'vi' or 'vim' ?
- is 'vi' an alias to vim ?  'type vi' ?

/bin/vi is a stripped-down version of vim and doesn't support all the fancy
options. Please make sure that you use /usr/bin/vim
Comment 2 Steve Fox 2002-11-12 09:12:06 EST
This happens for either 'vi' (alias to vim, see below), or im gvim. I had
thought that I tested this with some C source, but apparently that is working
now. However, my main concern is that this doesn't work in PHP mode. Note that
it *does* work if you manually type :set cindent in the editor. I have verified
that this work with Mandrake Linux 9, which uses the same php.vim file from
http://www.isp.de/data/php.vim dated 2002 Mar 11.

$ which vi
alias vi='vim'
        /usr/bin/vim

Note You need to log in before you can comment on or make changes to this bug.