Bug 729901 - usb.ids is missing in rebased usbutils package
Summary: usb.ids is missing in rebased usbutils package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbutils
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Jiri Moskovcak
QA Contact: WANG Chao
URL:
Whiteboard:
: 729842 (view as bug list)
Depends On:
Blocks: 729903
TreeView+ depends on / blocked
 
Reported: 2011-08-11 07:51 UTC by Caspar Zhang
Modified: 2015-02-08 21:42 UTC (History)
6 users (show)

Fixed In Version: usbutils-003-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
: 729903 (view as bug list)
Environment:
Last Closed: 2011-12-06 16:18:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1646 normal SHIPPED_LIVE usbutils bug fix and enhancement update 2011-12-06 00:50:34 UTC

Description Caspar Zhang 2011-08-11 07:51:38 UTC
Description of problem:

usb.ids is required by /usr/bin/lsusb.py command which is new in rebased usbutils package.

w/o this file, lsusb.py returns python errors like:

# lsusb.py 
 WARNING: Failure to read usb.ids
(<type 'exceptions.IOError'>, IOError(2, 'No such file or directory'), <traceback object at 0x7f0782d411b8>)
usb1            1d6b:0002 09  2.00 480MBit/s   0mA 1IFs (ehci_hcd 0000:00:1a.7) hub
usb2            1d6b:0002 09  2.00 480MBit/s   0mA 1IFs (ehci_hcd 0000:00:1d.7) hub
<snip>

# rpm -ql usbutils
/usr/bin/lsusb
/usr/bin/lsusb.py
/usr/bin/usb-devices
/usr/bin/usbhid-dump
/usr/share/doc/usbutils-003
/usr/share/doc/usbutils-003/AUTHORS
/usr/share/doc/usbutils-003/COPYING
/usr/share/doc/usbutils-003/ChangeLog
/usr/share/doc/usbutils-003/NEWS
/usr/share/doc/usbutils-003/README
/usr/share/man/man1/usb-devices.1.gz
/usr/share/man/man8/lsusb.8.gz
/usr/share/pkgconfig/usbutils.pc


Version-Release number of selected component (if applicable):
usbutils-003-1.el6.x86_64
kernel-2.6.32-184.el6.x86_64

How reproducible:
always

Comment 1 Jiri Moskovcak 2011-08-11 08:03:16 UTC
It's not missing it's packaged separately in package hwdata, I just didn't noticed libusb.py, so I didn't patched it. (I would expect it to honour the path to usb.ids from makefile, but it doesn't)

Comment 3 Jiri Moskovcak 2011-08-11 08:38:16 UTC
*** Bug 729842 has been marked as a duplicate of this bug. ***

Comment 4 Jiri Moskovcak 2011-08-11 08:38:32 UTC
Scratch build with fixed lsusb.py:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=3548218

Can you please try it and send me some feedback?

Comment 5 Caspar Zhang 2011-08-11 09:44:55 UTC
# lsusb.py 
usb1            1d6b:0002 09  2.00 480MBit/s   0mA 1IFs (ehci_hcd 0000:00:1a.7) hub
usb2            1d6b:0002 09  2.00 480MBit/s   0mA 1IFs (ehci_hcd 0000:00:1d.7) hub
usb3            1d6b:0001 09  1.10  12MBit/s   0mA 1IFs (uhci_hcd 0000:00:1a.0) hub

No more warning. Seems lsusb.py has found the right location of usb.ids now.

Comment 9 errata-xmlrpc 2011-12-06 16:18:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1646.html


Note You need to log in before you can comment on or make changes to this bug.