Bug 729904 - INFO: possible recursive locking detected - btrfs
Summary: INFO: possible recursive locking detected - btrfs
Keywords:
Status: CLOSED DUPLICATE of bug 731361
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 08:18 UTC by Matthias Runge
Modified: 2011-09-06 15:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 15:38:00 UTC


Attachments (Terms of Use)

Description Matthias Runge 2011-08-11 08:18:21 UTC
Description of problem:

Aug 11 06:38:12 localhost kernel: [ 2464.037255] 
Aug 11 06:38:12 localhost kernel: [ 2464.037258] =============================================
Aug 11 06:38:12 localhost kernel: [ 2464.038052] [ INFO: possible recursive locking detected ]
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 3.0.1-3.fc16.i686.PAE #1
Aug 11 06:38:12 localhost kernel: [ 2464.038052] ---------------------------------------------
Aug 11 06:38:12 localhost kernel: [ 2464.038052] updatedb/30000 is trying to acquire lock:
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  (&(&eb->lock)->rlock){+.+...}, at: [<f7b5340c>] btrfs_try_spin_lock+0x20/0x6f [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052] but task is already holding lock:
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  (&(&eb->lock)->rlock){+.+...}, at: [<f7b533e4>] btrfs_clear_lock_blocking+0x1a/0x22 [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052] other info that might help us debug this:
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  Possible unsafe locking scenario:
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052]        CPU0
Aug 11 06:38:12 localhost kernel: [ 2464.038052]        ----
Aug 11 06:38:12 localhost kernel: [ 2464.038052]   lock(&(&eb->lock)->rlock);
Aug 11 06:38:12 localhost kernel: [ 2464.038052]   lock(&(&eb->lock)->rlock);
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  *** DEADLOCK ***
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  May be due to missing lock nesting notation
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 2 locks held by updatedb/30000:
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  #0:  (&sb->s_type->i_mutex_key#13){+.+.+.}, at: [<c0512762>] vfs_readdir+0x4d/0x91
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  #1:  (&(&eb->lock)->rlock){+.+...}, at: [<f7b533e4>] btrfs_clear_lock_blocking+0x1a/0x22 [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052] 
Aug 11 06:38:12 localhost kernel: [ 2464.038052] stack backtrace:
Aug 11 06:38:12 localhost kernel: [ 2464.038052] Pid: 30000, comm: updatedb Not tainted 3.0.1-3.fc16.i686.PAE #1
Aug 11 06:38:12 localhost kernel: [ 2464.038052] Call Trace:
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c084512a>] ? printk+0x2d/0x2f
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c04731d7>] __lock_acquire+0x805/0xb57
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b5340c>] ? btrfs_try_spin_lock+0x20/0x6f [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c047393d>] lock_acquire+0xad/0xe4
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b5340c>] ? btrfs_try_spin_lock+0x20/0x6f [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c084d915>] _raw_spin_lock+0x3b/0x68
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b5340c>] ? btrfs_try_spin_lock+0x20/0x6f [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b5340c>] btrfs_try_spin_lock+0x20/0x6f [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b10b6c>] btrfs_search_slot+0x330/0x436 [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b6497d>] ? btrfs_get_delayed_node+0xb2/0xbc [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<f7b29519>] btrfs_real_readdir+0x20d/0x4ed [btrfs]
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c05124c8>] ? sys_ioctl+0x6a/0x6a
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c0473cda>] ? trace_hardirqs_on_caller+0xfe/0x11f
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c084cb00>] ? __mutex_lock_common+0x2e4/0x2ee
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c0512762>] ? vfs_readdir+0x4d/0x91
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c084cb96>] ? mutex_lock_killable_nested+0x43/0x49
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c0512781>] vfs_readdir+0x6c/0x91
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c05124c8>] ? sys_ioctl+0x6a/0x6a
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c051290a>] sys_getdents64+0x66/0xa8
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c084e354>] syscall_call+0x7/0xb
Aug 11 06:38:12 localhost kernel: [ 2464.038052]  [<c0840000>] ? timer_cpu_notify+0x1c5/0x201
Aug 11 06:38:13 localhost abrt-dump-oops: Reported 1 kernel oopses to Abrt
Aug 11 06:38:13 localhost abrtd: Directory 'oops-2011-08-11-06:38:13-630-0' creation detected
Aug 11 06:38:13 localhost abrtd: Can't open file '/var/spool/abrt/oops-2011-08-11-06:38:13-630-0/uid': No such file or directory
Aug 11 06:38:13 localhost abrtd: New dump directory /var/spool/abrt/oops-2011-08-11-06:38:13-630-0, processing



Version-Release number of selected component (if applicable):
3.0.1-3.fc16.i686.PAE
btrfs-progs-0.19-13.fc15.i686

Steps to Reproduce:
1. did a fresh install of f16 alpha rc3 in a kvm, I specified to use one of two cpus.
2. file system is btrfs (if that matters)
3.

Comment 1 Josh Boyer 2011-09-06 15:38:00 UTC

*** This bug has been marked as a duplicate of bug 731361 ***


Note You need to log in before you can comment on or make changes to this bug.