Bug 729913 - man rhnplugin.conf does not containt the most up2date information
Summary: man rhnplugin.conf does not containt the most up2date information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Kollar
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 09:09 UTC by Šimon Lukašík
Modified: 2015-07-22 07:25 UTC (History)
7 users (show)

Fixed In Version: yum-rhn-plugin-0.9.1-53
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:25:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1390 normal SHIPPED_LIVE yum-rhn-plugin bug fix and enhancement update 2015-07-20 17:58:08 UTC

Description Šimon Lukašík 2011-08-11 09:09:03 UTC
Description of problem:
The rhnplugin.conf manpage was not updated since 2006, while the code
base changed significantly in recent years.

The man page lists only gpgcheck= and enabled= options. Compared to
the yum-rhn-plugin included in RHEL6, which allows for example
priority= settings.

Man page should also mention configuration sections. And especially
the semantics of the [main] section.

Version-Release number of selected component (if applicable):
yum-rhn-plugin-0.9.1-26.el6.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. man rhnplugin.conf
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2011-10-07 16:20:41 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Matej Kollar 2015-02-12 15:42:38 UTC
It seems to me that all options available in `man rhnplugin.conf` are those that are described in `man yum.conf`. Maybe only change is that section names are labels of channels on RHN/Satellite/Spacewalk server. So whole man page can be dropped maybe except

  * mentioning man of yum.conf
  * and semantics for section names.
  * semantics of `enabled` in `[main]` section though that one is kind
    of obvious...

Mentioned setting `priority=` is available only when `priority` yum plugin is available and thus is configuration of that plugin (even though it has an impact on our plugin), so our man page is certainly not the right place explain its semantics.

Would it be OK to proceed this way?

Comment 8 Šimon Lukašík 2015-02-13 16:15:35 UTC
I see no problem.

Comment 9 Matej Kollar 2015-02-17 21:32:39 UTC
Upstream work
Spacewalk.git:

* 3fdde89785f7613f2872b87b23844889d4b77030
* 8624da7d1c8ee65205271d30e58b9bc405ec2cb3

Comment 14 errata-xmlrpc 2015-07-22 07:25:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1390.html


Note You need to log in before you can comment on or make changes to this bug.