Bug 729921 - validation fails because of hypervisor tag
Summary: validation fails because of hypervisor tag
Keywords:
Status: CLOSED DUPLICATE of bug 655837
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 09:45 UTC by Jan Stancek
Modified: 2014-12-08 01:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-11 13:59:14 UTC


Attachments (Terms of Use)

Description Jan Stancek 2011-08-11 09:45:43 UTC
Description of problem:
When cloning recipe in webui with:
<hypervisor op="=" value=""/>

validation of xml fails with:

Job failed schema validation. Please confirm that you want to submit it.

    * Line 22, col 0: Did not expect element hypervisor there
    * Line 23, col 0: Element and has extra content: hypervisor
    * Line 22, col 0: Element hostRequires has extra content: and
    * Line 6, col 0: Invalid sequence in interleave
    * Line 6, col 0: Element recipe failed to validate content
    * Line 5, col 0: Element recipeSet failed to validate content

If I remove this tag, there are no warnings.

How reproducible:
100%

Steps to Reproduce:
1. clone this recipe: 
https://beaker.engineering.redhat.com/jobs/clone?job_id=118956

Actual results:
validation fails (see above)

Expected results:
recipe should be accepted without warnings/errors

Additional info:

Comment 1 Steven Lawrance 2011-08-11 13:59:14 UTC
The fix for this was snuck in alongside that for bug 655837.

http://git.fedorahosted.org/git/?p=beaker.git;a=commitdiff;h=710472aac27dafd03a3d6ff51f49a61646e15a9b

*** This bug has been marked as a duplicate of bug 655837 ***


Note You need to log in before you can comment on or make changes to this bug.