Bug 72993 - Date & Time settings dialog hangs when NTP is selected
Date & Time settings dialog hangs when NTP is selected
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-date (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 15:35 EDT by Ian Clarke
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 15:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Clarke 2002-08-29 15:35:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
I bring up the Date/Time properties dialog, and select "Enable Network Time
Protocol".  I select a server, like "time.nist.gov" and hit Ok.  I then get a
small dialog saying "Contacting Time Server - Please Wait" which just sits there
until I kill it (I have left it for over 60 seconds).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Bring up Date/Time Properties dialog
2. Select "Enable NTP"
3. Select a Time Server
4. Hit OK
	

Actual Results:  It appears to hang.

Expected Results:  The dialog should go away after a brief delay, and my clock
should be set accurately.

Additional info:

I tried running "ntpdate" manually with one of the servers I tried and it
appeared to work fine.
Comment 1 Robert P. J. Day 2002-09-05 08:52:38 EDT
  i've had the same hanging behaviour, but just now, something a bit
different.  after i selected a different time server, the time was
updated almost immediately, but the small dialog box "Contacting time
server.  Please wait."  has not gone away.

  clearly, the time server was contacted since the time was updated,
but that dialog box shows no intention of ever disappearing.
Comment 2 Brent Fox 2002-10-22 15:06:18 EDT
Can you try with redhat-config-date-1.5.3-1 out of Rawhide and see if that fixes
the problem?  I was fixing some of this hanging behavior right up until the last
minute in 8.0.

Note You need to log in before you can comment on or make changes to this bug.