Fedora Account System
Red Hat Associate
Red Hat Customer
Reload operation for standalone AS7 seems to sometimes fail. Reason is that during reload, the server is closing its management socket for a short period of time. Depending on various influences (load on platform, swapped-in state etc.) this can happen before the server was able to send an answer. We need to treat this like the shutdown operation, where a connection refused is ignored as a valid (intermitted) outcome.
dac66dc on as7plugin
Pushed to master 40aab040
verified as follows: scheduled operation reload on AS7 server. the operation history reports no error, and i can see from the AS7 console that no errors occurred. then i scheduled a recurring operation on reload to occur 10 times, and no errors occurred.
marking VERIFIED BZs to CLOSED/CURRENTRELEASE
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE