Bug 729954 - alias interfaces causes lots of spam in messages
Summary: alias interfaces causes lots of spam in messages
Keywords:
Status: CLOSED DUPLICATE of bug 713286
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Laine Stump
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 11:45 UTC by Pierre Ossman
Modified: 2011-08-13 01:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-13 01:09:18 UTC


Attachments (Terms of Use)

Description Pierre Ossman 2011-08-11 11:45:20 UTC
I get loads and loads of these in messages whenever virt-manager is attached:

Aug  7 18:30:44 asgard libvirtd: 18:30:44.264: 14665: error : interfaceGetXMLDesc:355 : internal error could not get interface XML description (netcf: NETLINK socket operation failed - couldn't find ifindex for interface `eth1:0`)
Aug  7 18:30:45 asgard libvirtd: 18:30:45.069: 14662: error : interfaceGetXMLDesc:355 : internal error could not get interface XML description (netcf: NETLINK socket operation failed - couldn't find ifindex for interface `eth1:0`)
Aug  7 18:30:46 asgard libvirtd: 18:30:46.034: 14662: error : interfaceGetXMLDesc:355 : internal error could not get interface XML description (netcf: NETLINK socket operation failed - couldn't find ifindex for interface `eth1:0`)

eth1:0 is of course and alias, which explains why it cannot get a ifindex (it's not a real interface as far as the kernel is concerned). It is very much up though:

[root@asgard log]# ifconfig eth1:0
eth1:0    Link encap:Ethernet  HWaddr 00:1D:7D:04:0D:1B  
          inet addr:10.8.0.1  Bcast:10.8.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:29 Base address:0x2000 

This is using libvirt 0.8.7 on CentOS 6 (RHEL 6 package) with virt-manager 0.8.7 on Fedora 14.

(bug 673527 might be the same issue in a different form)

Comment 1 Dave Allan 2011-08-12 20:31:38 UTC
Laine, should this be moved to netcf?

Comment 2 Laine Stump 2011-08-13 01:09:18 UTC
Yes, it is a netcf bug. It's the same issue as Bug 713286, which is already fixed in netcf-0.1.9-1.

*** This bug has been marked as a duplicate of bug 713286 ***

Comment 3 Laine Stump 2011-08-13 01:28:23 UTC
Actually, I see this bug was filed against upstream, and although the problem has already been fixed upstream, there are no other bugs filed against that problem upstream, and upstream netcf has no specific category in bugzilla. The closest  to that are the netcf components of Fedora and RHEL (which makes some amount of sense, since there is currently no other port of netcf besides CentOS 6).

At any rate, the fix is in netcf-0.1.9.


Note You need to log in before you can comment on or make changes to this bug.