Bug 729961 - add the pt and zh locales to coregui
add the pt and zh locales to coregui
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
4.1
Unspecified Unspecified
medium Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-11 08:05 EDT by Heiko W. Rupp
Modified: 2013-08-05 20:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:27:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-08-11 08:05:35 EDT
Current 4.1.0 beta build is missing pt and zh translations, as they seem to not be enabled in settings.xml

We should find out how those builds can automatically include all locales without the need to manually tune settings.xml - perhaps by specifying no locales at all .

If this fails, we need a very simple process + readme on how to add new locales.
Comment 1 Ian Springer 2011-08-16 14:24:49 EDT
I've added the pt and zh locales with [master 3c15c6f]. The process is actually very simple - just add the locales to the gwt.locale property in coregui/pom.xml. Here's what that property looks like after my update:

        <!-- Comma-separated list of the locales that should be included during GWT compilation. The specified locales
             should each have two corresponding message bundle properties files under
             src/main/resources/org/rhq/enterprise/gui/coregui/client/. For example, the "ja" locale has
             Messages_ja.properties and MessageConstants_ja.properties. -->
        <gwt.locale>en,de,ja,pt,zh</gwt.locale>

Note, if you don't want building coregui on your local machine to take 15 minutes, make sure to add something like the following in the properties section of an active profile in your ~/.m2/settings.xml:

        <!-- Only compile the default locale. -->
        <gwt.locale>default</gwt.locale>
Comment 3 Mike Foley 2011-08-17 13:29:38 EDT
verified build 8/17 by visiting these URLs and seeing the correct language:

http://localhost:7080/coregui/CoreGUI.html?locale=de
http://localhost:7080/coregui/CoreGUI.html?locale=ja
Comment 5 Heiko W. Rupp 2011-08-18 03:26:13 EDT
All of comment 3 and comment 4 !
Comment 6 Mike Foley 2012-02-07 14:27:00 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.