Bug 729981 - zipl requires C locale with /boot on LVM
Summary: zipl requires C locale with /boot on LVM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Dan Horák
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 13:08 UTC by Dan Horák
Modified: 2011-12-06 18:02 UTC (History)
6 users (show)

Fixed In Version: s390utils-1.8.2-37.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:45:26 UTC


Attachments (Terms of Use)
run helper script in C locale (1.02 KB, patch)
2011-08-11 15:07 UTC, Dan Horák
no flags Details | Diff
s390-tools-rhel6-zipl_helper_locale.patch (1.21 KB, text/plain)
2011-08-19 10:40 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1525 normal SHIPPED_LIVE s390utils bug fix and enhancement update 2011-12-06 01:02:25 UTC
IBM Linux Technology Center 74154 None None None Never

Description Dan Horák 2011-08-11 13:08:53 UTC
Description of problem:
When /boot is a logical volume and non-C (or non-english) locale is used then zipl fails with an error.

[root@devel2 ~]# zipl
Using config file '/etc/zipl.conf'
Run /lib/s390-tools/zipl_helper.device-mapper /boot/
Error: Could not determine partition start for dasda1
Error: Script could not determine target parameters


Version-Release number of selected component (if applicable):
s390utils-1.8.2-36.el6.s390x

How reproducible:
100%

Steps to Reproduce:
1. zipl
  
Actual results:
[root@devel2 ~]# zipl
Using config file '/etc/zipl.conf'
Run /lib/s390-tools/zipl_helper.device-mapper /boot/
Error: Could not determine partition start for dasda1
Error: Script could not determine target parameters

Expected results:
[root@devel2 ~]# LANG=C zipl
Using config file '/etc/zipl.conf'
Run /lib/s390-tools/zipl_helper.device-mapper /boot/
Building bootmap in '/boot/'
Building menu 'rh-automatic-menu'
Adding #1: IPL section 'linux-2.6.32-131.0.15.el6.s390x' (default)
Preparing boot device: dasda.
Done.

Comment 1 Dan Horák 2011-08-11 15:07:54 UTC
Created attachment 517826 [details]
run helper script in C locale

Comment 2 Dan Horák 2011-08-11 15:18:17 UTC
My locale is "cs_CZ.UTF-8" and the tool with translated output is blockdev.

Comment 4 IBM Bug Proxy 2011-08-19 10:40:28 UTC
Created attachment 519007 [details]
s390-tools-rhel6-zipl_helper_locale.patch


------- Comment on attachment From brueckner@linux.vnet.ibm.com 2011-08-19 06:31 EDT-------


Description: zipl: localized scripting output leads to errors
Symptom:     zipl is terminated with an error:
	     "Script could not determine target parameters"
Problem:     zipl uses zipl_helper.device-mapper to print zipl parameters 
	     for device mapper devices. This script parses the output
	     of other programs that might have a locale dependent
	     output. If so, the script is unable to parse the output.
Solution:    Setup and use a standard locale to avoid localized
	     scripting output.

Comment 6 errata-xmlrpc 2011-12-06 17:45:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1525.html


Note You need to log in before you can comment on or make changes to this bug.