Bug 729982 - yum-plugin-auto-update-debug-info-1.1.31-1.fc17 breaks yum for me.... downgrading to -1.1.30-3.fc17 fixes it for me
yum-plugin-auto-update-debug-info-1.1.31-1.fc17 breaks yum for me.... downgra...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 729964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-11 09:14 EDT by Tom London
Modified: 2014-01-21 18:19 EST (History)
9 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 22:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix hasattr() argument (486 bytes, patch)
2011-08-13 06:57 EDT, Martin-Gomez Pablo
no flags Details | Diff

  None (edit)
Description Tom London 2011-08-11 09:14:43 EDT
Description of problem:

[root@tlondon packages]# yum --skip-broken update
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 315, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 140, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 458, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 100, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 111, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 893, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 673, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 265, in populateSack
    self.doSetup()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup
    self.ayum.plugins.run('prereposetup')
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 121, in prereposetup_hook
    enable_debuginfo_repos(yb, conduit)
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 41, in enable_debuginfo_repos
    if opts is not None and hasattr(opts.repos) :
TypeError: hasattr expected 2 arguments, got 1
[root@tlondon packages]# 

Happens with every yum command I tried

Version-Release number of selected component (if applicable):
yum-utils-1.1.31-1.fc17.noarch.rpm
yum-plugin-auto-update-debug-info-1.1.31-1.fc17.noarch.rpm
yum-3.4.3-6.fc17.noarch

How reproducible:
Every time I run 'yum .....'

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Eike Hein 2011-08-12 15:53:45 EDT
Similar failure on F15 with yum-plugin-auto-update-debug-info-1.1.31-1.fc15.noarch on 'yum upgrade':

Loaded plugins: auto-update-debuginfo, presto
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 267, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 120, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 428, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 99, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 110, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 859, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 645, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 260, in populateSack
    self.doSetup()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup
    self.ayum.plugins.run('prereposetup')
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 121, in prereposetup_hook
    enable_debuginfo_repos(yb, conduit)
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 41, in enable_debuginfo_repos
    if opts is not None and hasattr(opts.repos) :
TypeError: hasattr expected 2 arguments, got 1
Comment 2 Martin-Gomez Pablo 2011-08-13 06:57:12 EDT
Created attachment 518143 [details]
Fix hasattr() argument

Here is a patch ; works for me but I'm not sure it's the right fix to do
Comment 4 Tom London 2011-08-13 10:05:17 EDT
(In reply to comment #3)
> fixed upstream
> 
> http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=efb3c7b3fb96523bb5997c163bf4e33ab897f1b8

Locally applying this patch 'makes it work for me'.
Comment 5 Fedora Update System 2011-08-13 12:23:53 EDT
yum-utils-1.1.31-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-2.fc16
Comment 6 Fedora Update System 2011-08-13 12:24:12 EDT
yum-utils-1.1.31-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-2.fc15
Comment 7 Martin-Gomez Pablo 2011-08-14 12:53:25 EDT
Ok, so my patch was fucked up ^^' Works for me know with the 1.1.31-2 version
Comment 8 Fedora Update System 2011-08-15 16:26:16 EDT
Package yum-utils-1.1.31-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-2.fc16
then log in and leave karma (feedback).
Comment 9 Tim Lauridsen 2011-08-16 01:18:38 EDT
*** Bug 729964 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2011-08-17 22:37:16 EDT
yum-utils-1.1.31-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-08-22 10:46:33 EDT
yum-utils-1.1.31-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.