Bug 730013 - Trying to build an EC2 upload style RHEL-5 i386 image fails
Summary: Trying to build an EC2 upload style RHEL-5 i386 image fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 0.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mike Orazi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 14:29 UTC by Chris Lalancette
Modified: 2011-12-08 14:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 19:53:30 UTC


Attachments (Terms of Use)

Description Chris Lalancette 2011-08-11 14:29:34 UTC
Description of problem:
When trying to build an EC2 upload style RHEL-5 i386 image, the image factory throws an exception:


2011-08-11 10:08:18,795 INFO imgfac.builders.BaseBuilder.RHEL5_ec2_Builder pid(1858) Message: Modifying and updating menu.lst
2011-08-11 10:08:18,808 DEBUG imgfac.builders.BaseBuilder.RHEL5_ec2_Builder pid(1858) Message: Exception caught in ImageFactory
2011-08-11 10:08:18,827 DEBUG imgfac.builders.BaseBuilder.RHEL5_ec2_Builder pid(1858) Message: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 170, in build_upload
    self.ec2_modify_filesystem()
  File "/usr/lib/python2.7/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 387, in ec2_modify_filesystem
    raise ImageFactoryException("Unable to extract kernel version")
ImageFactoryException: Unable to extract kernel version


After talking to Ian on IRC, the problem is that the factory goes looking for an installed Xen kernel during ec2_modify_filesystem().  If you didn't explicitly specify that in the TDL, you will hit this message.  My thinking is that we should probably force install the -xen kernel when we know we are doing EC2 upload style RHEL-5 i386 builds.

Comment 1 wes hayutin 2011-08-30 19:53:30 UTC
upload RHEL is not supported

Comment 2 wes hayutin 2011-12-08 14:09:32 UTC
perm close


Note You need to log in before you can comment on or make changes to this bug.