Bug 730044 - matahari-host shutdown/reboot not graceful
Summary: matahari-host shutdown/reboot not graceful
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 15:45 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
3 users (show)

Fixed In Version: matahari-0.4.2-7.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-11 15:45:25 UTC
Description of problem:
=======================
Not sure what the requirement is but I was expecting that the matahari host agent shutdown and reboot methods would gracefully shutdown the OS, it doesn't.  It seems to do a immediate halt (and then if reboot, begins to boot)

Version-Release number of selected component (if applicable):
=============================================================
matahari-host-0.4.2-5.el6.x86_64

How reproducible:
=================
100%

Steps to Reproduce:
===================
1.  on a vm, install matahari broker and host
2.  start broker and agent
3.  issue shutdown or reboot to matahari host agent 
4.  see vm, it halts immediately

Comment 2 Andrew Beekhof 2011-08-15 06:17:29 UTC
We use the standard reboot() function (man 2 reboot).
VMs just shut down really quickly.

void
host_os_reboot(void)
{
    reboot(LINUX_REBOOT_CMD_RESTART);
}

void
host_os_shutdown(void)
{
    reboot(LINUX_REBOOT_CMD_HALT);
}

Comment 3 Andrew Beekhof 2011-08-18 04:27:27 UTC
A related patch has been committed upstream: https://github.com/beekhof/matahari/commit/3eaaf04

Comment 4 Andrew Beekhof 2011-08-18 04:29:51 UTC
qmf: call 2 reboot

Broadcast message from root@pcmk-1
	(unknown) at 0:58 ...

The system is going down for reboot NOW!


In another window while watching /var/log/messages...

Broadcast message from root@pcmk-1
	(unknown) at 0:58 ...

The system is going down for reboot NOW!
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty1) main process (1244) killed by TERM signal
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty2) main process (1246) killed by TERM signal
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty3) main process (1248) killed by TERM signal
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty4) main process (1250) killed by TERM signal
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty5) main process (1252) killed by TERM signal
Aug 18 00:58:43 pcmk-1 init: tty (/dev/tty6) main process (1254) killed by TERM signal
Aug 18 00:58:43 pcmk-1 pacemakerd: [13869]: info: crm_signal_dispatch: Invoking handler for signal 15: Terminated


This indicates a "normal" shutdown occurred.

Comment 6 Dave Johnson 2011-08-19 20:32:12 UTC
good 2 go in v0.4.2-7 for both shutdown and reboot methods

Comment 7 Russell Bryant 2011-11-16 21:40:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 8 errata-xmlrpc 2011-12-06 11:39:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.