Bug 730065 - (Drift) Detail views don't go away when navigating directly to a new subtab
(Drift) Detail views don't go away when navigating directly to a new subtab
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
All All
urgent Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-11 12:44 EDT by Jay Shaughnessy
Modified: 2012-02-07 14:19 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-08-11 12:44:23 EDT
This is easily seen in the Drift View but it occurs in other views as well.

1) Generated at least one Drift History entry

2) Navigate to the Drift->History subtab

3) Double click on an entry to bring up the drift detail

4) Click on the Drift->Configuration subtab (you can wait for this to render)

5) Click again on Drift->History subtab

Since the detail view is still hanging around, but clicking the subtab will always bring you to the list view, both views are displayed with the detail being forced to the right (not always within view in certain tabs, and therefore the problem is not always apparent).

There are two solutions:
1) Ensure the detail view is destroyed so it does not show up.
2) Since we navigated away from the detail view, return to the detail view when the History subtab is revisited.

I think I prefer option 1 but I'll ask around.
Comment 1 Jay Shaughnessy 2011-08-17 10:39:55 EDT
Master commit: 5134f1e7f56086a377a74203cdb829b84187fc5b
Comment 2 Mike Foley 2011-08-17 14:42:20 EDT
seeing multiple "Failed to Fetch Drift Data".  (already logged)
i have seen this issue with other detail views yesterday.  (already logged)
i am marking this verified for drift detail view only (do not dupe the meta case of detail views not going away on this verification).
Comment 3 Mike Foley 2011-08-17 17:15:34 EDT
adding better documentation of (already logged) comments:

1)  the BZ with the multiple details views is 719976 (verified now)
2)  Failed to fetch drift history BZ = 731573
Comment 4 Mike Foley 2012-02-07 14:19:55 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.