Bug 730095 - USB HDD reattach itself after udisks --detach
Summary: USB HDD reattach itself after udisks --detach
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: udisks
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 18:25 UTC by Grzegorz Chojnacki
Modified: 2013-03-06 04:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 15:55:04 UTC


Attachments (Terms of Use)
full output off dmesg (71.95 KB, text/plain)
2011-08-12 14:54 UTC, Grzegorz Chojnacki
no flags Details
Output of lsusb after first detach (483 bytes, text/plain)
2011-08-12 14:57 UTC, Grzegorz Chojnacki
no flags Details
lspci output (2.23 KB, text/plain)
2011-08-12 23:05 UTC, Grzegorz Chojnacki
no flags Details

Description Grzegorz Chojnacki 2011-08-11 18:25:25 UTC
Description of problem:
My external HDD is Toshiba Store alu2. In Windows it's regular way of working is: when system is on and USB powered HDD stays active, then if you "safely remove" or turn off computer disk go into sleep when it's safe to turn off electricity. In linux (not only Fedora) if I simply turn off computer disk stays put, so I've done some check and found option to "safely remove" in Nautilus. But it did not work as intended. The HDD gone sleep and awakens straight away, partition mounts again and then after about 30 seconds when it finalize mounting I'm able to "safely remove" again and it works this time alright. First I thought it's Nautilus fault, but I was suggested by someone to do udisks --unmount /dev/sda1 and then udisks --detach /dev/sda, but it also neeeds doubling to work. I also tried logging out of X11 and doing it in bare console but still no lock. The output of dmesg | tail gives:
[   69.399701] sd 10:0:0:0: [sda] Write Protect is off
[   69.399713] sd 10:0:0:0: [sda] Mode Sense: 38 00 00 00
[   69.408677] sd 10:0:0:0: [sda] No Caching mode page present
[   69.408687] sd 10:0:0:0: [sda] Assuming drive cache: write through
[   69.438673] sd 10:0:0:0: [sda] No Caching mode page present
[   69.438685] sd 10:0:0:0: [sda] Assuming drive cache: write through
[   73.662860]  sda: sda1
[   73.718779] sd 10:0:0:0: [sda] No Caching mode page present
[   73.718792] sd 10:0:0:0: [sda] Assuming drive cache: write through
[   73.718801] sd 10:0:0:0: [sda] Attached SCSI disk
after my first attemt to detach.

Version-Release number of selected component (if applicable):


How reproducible:
does it every time

Steps to Reproduce:
1.Turn on computer with USB_HDD attached to port.
2.Unmount all partitions of HDD then execute udisks --detach /dev/sdx
3.The HDD will detach and reattach again
  
Actual results:
HDD reattaches itself and mounts again

Expected results:
HDD goes to sleep

Additional info: Fedora 15 64bits with gnome 3, athlone CPU

Comment 1 Grzegorz Chojnacki 2011-08-12 14:54:17 UTC
Created attachment 518045 [details]
full output off dmesg

This is full output of dmesg. I started computer, opened console, unmounted /dev/sda1, executed udisks --detach /dev/sda and then done dmesg with folowing output. Looks like it closes port USB 1.1 and then runs it as port USB 3.1.

Comment 2 Grzegorz Chojnacki 2011-08-12 14:57:12 UTC
Created attachment 518046 [details]
Output of lsusb after first detach

This is output of lsusb after udisks --detach done first time. Lumberg Inc. is my Toshiba HDD. After wake up it shows up as Bus 001 Device 002, then when reattach it is as follows in the output file

Comment 3 Grzegorz Chojnacki 2011-08-12 17:44:55 UTC
Tested also with Kingston Pendrive and Canon Photo Camera with same results on dmesg and lsusb.

Comment 4 Grzegorz Chojnacki 2011-08-12 23:05:21 UTC
Created attachment 518122 [details]
lspci output

my output from lspci if needed.

Comment 5 Fedora End Of Life 2012-08-07 15:55:06 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.