Bug 7301 - logrotate rotating last login database /var/log/lastlog
logrotate rotating last login database /var/log/lastlog
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 14:07 EST by Andrew Turnquist
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-24 13:03:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Turnquist 1999-11-24 14:07:01 EST
Since version 4.x, the logrotate package has erronously been rotating
/var/log/lastlog.  This file does not need to be rotated.  It is a file
of records of last login times, indexed by UID.  It only grows with the
addition of new users.  By rotating (and erasing) this file, users' last
login time and location are forgotten each month.  The solution is to
remove the section for lastlog from /etc/logrotate.conf.

Note that if there is a large gap of unused UIDs, this file may seem
larger than it really is (as it will be a sparse file).  Use
'du /var/log/lastlog' to determine its actual usage.

If there is some other reason for this file being rotated, I would be
interested in seeing that reasoning.

Thanks,
	--Andrew
Comment 1 Erik Troan 2000-02-24 13:03:59 EST
Fixed for logrotate 3.3.2  -- thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.