Bug 730101 - console is not properly released in interactive virsh
Summary: console is not properly released in interactive virsh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Eric Blake
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 19:08 UTC by Dave Allan
Modified: 2016-04-26 16:45 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:26:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Dave Allan 2011-08-11 19:08:12 UTC
If I start virsh in interactive mode and get a serial console on a VM, then exit the console, then re-enter the console, I get garbage output consistent with two console sessions being started simultaneously.

Steps to reproduce:
1) start virsh in interactive mode
2) start $VM
3) console $VM
  At this point console output should be normal.
4) exit console with ^]
5) console $VM
  At this point the console output will be garbled.  Also, destroying the VM and then trying to get a console hangs (I waited over half an hour) instead of reporting that the VM is down.

Comment 6 Vivian Bian 2011-09-21 09:58:55 UTC
tested with  PASSED 
libvirt-0.9.4-12.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64
kernel-2.6.32-197.el6.x86_64

Steps:
1) start virsh in interactive mode
2) start $VM
3) console $VM
  At this point console output should be normal.
4) exit console with ^]
5) console $VM

Actual result
All of the guest starting process could be exactly caught and outputted , there is no garbled output for me . 

According to the above , set bug status to VERIFIED

Comment 7 errata-xmlrpc 2011-12-06 11:26:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.