Bug 730114 - Subscriptions no longer readable by accessibility api
Summary: Subscriptions no longer readable by accessibility api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Michael Stead
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-11 19:40 UTC by J.C. Molet
Modified: 2011-12-06 17:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:26 UTC


Attachments (Terms of Use)
blank row names (156.50 KB, image/png)
2011-08-11 19:40 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description J.C. Molet 2011-08-11 19:40:45 UTC
Created attachment 517880 [details]
blank row names

Description of problem:
The rows in the subscriptions column of the "All Available Subscriptions" tab do not have any accessibility name. This also applies to the subscriptions in the Subscription Assistant. This means accessibility readers can't tell what is there and this blocks automation of anything involving subscribing or unsubscribing.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.5-1.git.19.8802aeb.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Open subscription manager gui
2. Register
3. Try read any cell in column 0 in the "All Subscriptons View" in the "all available subscriptions" tab or the "Subscriptions List" in the subscription assistant.  (see my screenshot using sniff)
  
Actual results:
The cells have no accessibility name and cannot be read.

Expected results:
The cell would be named the same thing as the subscription name.  In the screenshot, for example, the highlighted cell in the AT-SPI Browser would be named the same thing as It's 3rd child:  "Awesome OS Serrver Basic".  Alternatively the other information the cells could be moved to its own column.

Additional info:

Comment 1 Michael Stead 2011-08-24 17:21:35 UTC
This was fixed a while ago. I forgot to close the issue. :(

Fix committed in master branch - 7cbb9d15dd7d41722479781b72ade7c31fe67481

Comment 3 J.C. Molet 2011-08-30 17:18:37 UTC
verified.  The extra info was moved to their own unique column.

subscription-manager-gnome-0.96.8-1.git.0.125eb68.el6.x86_64

Comment 4 errata-xmlrpc 2011-12-06 17:23:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.