Bug 730135 - gcalctool in Advanced mode doesn't change numeric representation
Summary: gcalctool in Advanced mode doesn't change numeric representation
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcalctool
Version: 15
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 20:53 UTC by luigi votta
Modified: 2011-08-12 16:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-12 16:57:25 UTC


Attachments (Terms of Use)

Description luigi votta 2011-08-11 20:53:19 UTC
Description of problem:
In Programming mode, the numerical represention (dec, binary, oct, hex) seems not react normally. Inserting a number in the display and than changing the representation the numeric value in the display doesn't change.

Version-Release number of selected component (if applicable):
gcalctool-6.0.1-2.fc15.i686

How reproducible:
100%

Steps to Reproduce:
1. In Programming mode, insert a number in the display: e.g 5 decimal
2. Change the numeric representation into binary 

Actual results:
5  

Expected results:
101 (binary)

Additional info:

Comment 1 luigi votta 2011-08-11 22:05:47 UTC
Ok it is not a bug, it's a lacking event in the control.

Please re-give us this advanced FUNCTIONALITY. 
We don't use the calc to make only elementary operation in decimal representation!

Many thanks

Comment 2 luigi votta 2011-08-12 16:57:25 UTC
After inserting the numerical values pressing enter, it bolds them and all gets right. 

Sorry


Note You need to log in before you can comment on or make changes to this bug.