Bug 730148 - Adobe Reader could not start after enabling SSSD [NEEDINFO]
Summary: Adobe Reader could not start after enabling SSSD
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acroread
Version: 5.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 22:04 UTC by Simon Gao
Modified: 2014-06-02 13:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:09:34 UTC
pm-rhel: needinfo? (gao)


Attachments (Terms of Use)

Description Simon Gao 2011-08-11 22:04:36 UTC
Description of problem:

Adobe Reader program failed to start after enabling SSSD service. 

Version-Release number of selected component (if applicable):

RHEL 5.6 X86_64  2.6.18-238.12.1.el5xen

How reproducible:


Steps to Reproduce:
1. Fresh install 5.6 X86_64 with all updates
2. Install AdbeRdr9.4.2-1_i486linux_enu.bin
3. Configure SSSD with LDAP domain, nsswitch.conf, system-auth 
4. Log in as a user authenticated against LDAP directory. 
5. Start acroread:

  
Actual results:

Starting aroread from command gave following error:

(acroread:17982): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (9026)

Expected results:

Adobe reader should launch and open a window.

Additional info:

Comment 1 Marek Kašík 2011-08-12 07:38:10 UTC
Hi,

the problem is caused by absence of package "sssd-client.i686"in your system. We are also solving this problem in Red Hat Enterprise Linux 6 now but it is not finished yet.
Installation of the package "sssd-client.i686" should solve the problem for you.

Regards

Marek

Comment 2 RHEL Product and Program Management 2014-03-07 13:41:23 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Product and Program Management 2014-06-02 13:09:34 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.