Bug 730178 - [abrt] kernel: WARNING: at drivers/net/wireless/iwlegacy/iwl-core.c:1436 iwl_legacy_mac_remove_interface+0x98/0x128 [iwl_legacy](): TAINTED P--------W
Summary: [abrt] kernel: WARNING: at drivers/net/wireless/iwlegacy/iwl-core.c:1436 iwl_...
Keywords:
Status: CLOSED DUPLICATE of bug 757541
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:751e2a5df3fc291cb1cb91b9d12...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 02:52 UTC by Shuresh Williams
Modified: 2012-01-21 13:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-21 13:47:19 UTC


Attachments (Terms of Use)

Description Shuresh Williams 2011-08-12 02:52:47 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=/dev/mapper/vg_saintjud-lv_root rd_LVM_LV=vg_saintjud/lv_root rd_LVM_LV=vg_saintjud/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet nouveau.modeset=0 rdblacklist=nouveau
comment:        Running Yum updates
component:      kernel
kernel:         2.6.40-4.fc15.x86_64
kernel_tainted: 513
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         WARNING: at drivers/net/wireless/iwlegacy/iwl-core.c:1436 iwl_legacy_mac_remove_interface+0x98/0x128 [iwl_legacy]()
time:           Thu Aug 11 14:38:37 2011

backtrace:
:WARNING: at drivers/net/wireless/iwlegacy/iwl-core.c:1436 iwl_legacy_mac_remove_interface+0x98/0x128 [iwl_legacy]()
:Hardware name: Z84J
:Modules linked in: fuse ppdev parport_pc lp parport sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf rfcomm bnep arc4 nvidia(P) snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm btusb bluetooth r592 memstick snd_timer iwl4965 iwl_legacy mac80211 snd microcode iTCO_wdt iTCO_vendor_support soundcore serio_raw joydev snd_page_alloc i2c_i801 sky2 i2c_core cfg80211 asus_laptop sparse_keymap rfkill mmc_block video firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t [last unloaded: scsi_wait_scan]
:Pid: 860, comm: NetworkManager Tainted: P            2.6.40-4.fc15.x86_64 #1
:Call Trace:
: [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81054cc0>] warn_slowpath_null+0x1a/0x1c
: [<ffffffffa0184f86>] iwl_legacy_mac_remove_interface+0x98/0x128 [iwl_legacy]
: [<ffffffffa00fa74a>] drv_remove_interface+0x37/0x3c [mac80211]
: [<ffffffffa00fbca8>] ieee80211_do_stop+0x306/0x460 [mac80211]
: [<ffffffff813f2ef5>] ? dev_deactivate_many+0x116/0x15e
: [<ffffffffa00fbe1c>] ieee80211_stop+0x1a/0x1e [mac80211]
: [<ffffffff813d89fa>] __dev_close_many+0xa5/0xd6
: [<ffffffff813d8a5f>] __dev_close+0x34/0x49
: [<ffffffff814b71bc>] ? _raw_spin_unlock_bh+0x15/0x17
: [<ffffffff813dcc97>] __dev_change_flags+0xab/0x12f
: [<ffffffff813dcd94>] dev_change_flags+0x1e/0x54
: [<ffffffff813e7ae9>] do_setlink+0x2b0/0x779
: [<ffffffff813e8218>] rtnl_setlink+0xcd/0xed
: [<ffffffff813e8523>] rtnetlink_rcv_msg+0x1ea/0x200
: [<ffffffff813e8339>] ? __rtnl_unlock+0x17/0x17
: [<ffffffff813fbb4b>] netlink_rcv_skb+0x42/0x8d
: [<ffffffff813e7607>] rtnetlink_rcv+0x26/0x2d
: [<ffffffff813fb655>] netlink_unicast+0xec/0x156
: [<ffffffff813fb93f>] netlink_sendmsg+0x280/0x2b8
: [<ffffffff813c975d>] sock_sendmsg+0xe6/0x109
: [<ffffffff814539f5>] ? scm_destroy+0x2b/0x4c
: [<ffffffff81041325>] ? should_resched+0xe/0x2d
: [<ffffffff814b5abc>] ? _cond_resched+0xe/0x22
: [<ffffffff813d343e>] ? copy_from_user+0x2f/0x31
: [<ffffffff813d3829>] ? verify_iovec+0x52/0xa5
: [<ffffffff813c9a0d>] __sys_sendmsg+0x1de/0x262
: [<ffffffff810451ae>] ? perf_event_task_sched_out+0x29/0x61
: [<ffffffff81042cb3>] ? set_next_entity+0x45/0x97
: [<ffffffff8100803a>] ? paravirt_write_msr+0x14/0x18
: [<ffffffff81008775>] ? __switch_to+0x141/0x220
: [<ffffffff8123b6a2>] ? rb_insert_color+0x66/0xe1
: [<ffffffff8104522f>] ? finish_task_switch+0x49/0xb7
: [<ffffffff813cb5ee>] sys_sendmsg+0x42/0x60
: [<ffffffff814bd7c2>] system_call_fastpath+0x16/0x1b

kernel_tainted_long:
:Proprietary module has been loaded.
:Taint on warning.

Comment 1 Stanislaw Gruszka 2011-08-13 20:55:29 UTC
Does it happens every time you are doing yum update?

Comment 2 Stanislaw Gruszka 2011-08-13 20:56:51 UTC
Can you attach all kernel messages from kernel boot to above call trace?

Comment 3 Stanislaw Gruszka 2012-01-10 17:38:08 UTC
Any chance that we can get more info on this issue?

Comment 4 Stanislaw Gruszka 2012-01-21 13:47:19 UTC

*** This bug has been marked as a duplicate of bug 757541 ***


Note You need to log in before you can comment on or make changes to this bug.