Bug 7302 - Can't copy between genome-terminal and Bugzilla.
Can't copy between genome-terminal and Bugzilla.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 14:52 EST by georgel
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 15:04:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description georgel 1999-11-24 14:52:06 EST
I can copy from genome-terminal to genome-terminal but the same buffer wont
copy into the Bugzilla description panel.  See bug 7297. Bugzilla doesn't
think it's their problem.
Comment 1 Havoc Pennington 1999-11-29 12:22:59 EST
I can't reproduce this. Can you give me the output of 'gnome-terminal --version'
and perhaps some more specific steps to cause the bug.
Comment 2 georgel 1999-11-30 09:47:59 EST
Terminal help about indicates
GNOME Terminal 1.0.39

nxterm -version retrurns:
XFree86 3.3.3.1b(88b)

I can copy text from one Termial to another by highlighting in one Terminal and
edit paste in another Terminal, or somewhere else in the same terminal.
I can also highlight text in the nxterm window and paste it into the Terminal
window.

When trying to copy into the Bugzilla window (particulary the Additonal Comments
setion ) The edit paste menu item is not active. C-v doesn't work either.
Comment 3 Joe Harrington 1999-12-21 18:09:59 EST
I can't always copy from gnome-terminal to emacs, or vice versa, ditto
netscape.  Ditto netscape-emacs.  Ditto gnome-terminal to the same
gnome-terminal!  It seems that if there's something in the X buffer
from emacs or xterm, it's "stickier" than what's later coming in from
gnome-terminal or netscape, and the older emacs stuff gets pasted
instead.  You can't cut a zero-length selection to clear the problem,
but sometimes waiting will clear it.  It always works to go between
emacs and xterm.

Try this:
start emacs and gnome-termina, get some text in them
cut something in emacs, note the highlighting
cut something in gnome-terminal, note that emacs highlighting isn't
    going away
paste in either place
the earlier emacs selection gets pasted

The exact same behavior happens with xterm.  I'm using Gnome Terminal
1.0.39 which is in gnome-core-1.0.39-10.

Someone once told me that there is more than one mechanism that
implements cut-and-paste in X11, and this might be at the root of the
problem.

--jh--
Comment 4 Havoc Pennington 2000-02-03 15:04:59 EST
It all works if you use middle mouse to paste and left mouse to copy.
The problem is varying (all probably reasonable) ideas about what the
cut/copy/paste menu items should actually do.

There are two important X selections, PRIMARY and CLIPBOARD. You are
supposed to use PRIMARY for the middle-mouse-to-paste stuff and CLIPBOARD
for the cut/copy/paste menu items. But gnome-terminal uses PRIMARY for
paste because xterm traditionally does this. Netscape probably uses CLIPBOARD
for the menu and PRIMARY for the mouse-buttons-only stuff. Qt/KDE applications
are all broken and use PRIMARY for the cut/copy/paste menu items.

I would say that Netscape does the right thing, and gnome-terminal arguably
does the right thing because of the xterm tradition, but text editors and such
should definitely be using CLIPBOARD for cut/copy/paste menu items.

Anyway it's a big historical mess, but it's unclear what to fix.

Note You need to log in before you can comment on or make changes to this bug.