Bug 730221 - Windows i386 guests with multiple vcpus BSOD during rebooting on AMD hosts
Summary: Windows i386 guests with multiple vcpus BSOD during rebooting on AMD hosts
Keywords:
Status: CLOSED DUPLICATE of bug 720936
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 08:15 UTC by Qixiang Wan
Modified: 2011-08-23 11:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 11:57:21 UTC


Attachments (Terms of Use)
Windows XP BSOD (17.48 KB, image/png)
2011-08-12 08:17 UTC, Qixiang Wan
no flags Details
Dom 2 BSOD while rebooting (24.57 KB, text/plain)
2011-08-12 08:51 UTC, Qixiang Wan
no flags Details
qemu-dm log (2.84 KB, text/plain)
2011-08-12 08:52 UTC, Qixiang Wan
no flags Details

Description Qixiang Wan 2011-08-12 08:15:26 UTC
Description of problem:
Windows i386 guests with multiple vcpus will BSOD on AMD i386 hosts, We saw the BSOD when it reboot after installation complete, and can reproduce it by reboot the guest with 2 vcpus.

On AMD x86_64 hosts, the guest may keep hanging there while rebooting.

No issue found on Intel hosts.
Single vcpu guest works well on AMD hosts.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-238.21.1.el5

How reproducible:
100%

Steps to Reproduce:
1. install a windows i386 guest with 2vcpus on AMD i386 host, or reboot a pre-installed guest.
  
Actual results:
BSOD on i386 hosts
Hang on x86_64 hosts

Expected results:
Guest should work well


Additional info:
[1] it may be the same issue with 
https://bugzilla.redhat.com/show_bug.cgi?id=723854

I can reproduce the BSOD with

Comment 1 Qixiang Wan 2011-08-12 08:16:44 UTC
> I can reproduce the BSOD with
sorry, lost the version: kernel-xen-2.6.18-278.el5

Comment 2 Qixiang Wan 2011-08-12 08:17:54 UTC
Created attachment 517984 [details]
Windows XP BSOD

Comment 3 Qixiang Wan 2011-08-12 08:51:26 UTC
Created attachment 517989 [details]
Dom 2 BSOD while rebooting

Comment 4 Qixiang Wan 2011-08-12 08:52:00 UTC
Created attachment 517990 [details]
qemu-dm log

Comment 6 RHEL Product and Program Management 2011-08-12 16:29:50 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Paolo Bonzini 2011-08-23 11:57:21 UTC

*** This bug has been marked as a duplicate of bug 720936 ***


Note You need to log in before you can comment on or make changes to this bug.