Bug 730225 - ld segv on linking libreoffice library
Summary: ld segv on linking libreoffice library
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 08:36 UTC by Caolan McNamara
Modified: 2011-12-21 17:01 UTC (History)
3 users (show)

Fixed In Version: binutils-2.21.53.0.1-6.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-21 17:01:11 UTC


Attachments (Terms of Use)
preprocessed soruce (4.07 MB, application/octet-stream)
2011-08-12 08:36 UTC, Caolan McNamara
no flags Details

Description Caolan McNamara 2011-08-12 08:36:36 UTC
Created attachment 517986 [details]
preprocessed soruce

Description of problem:

Version-Release number of selected component (if applicable):
binutils-2.21.53.0.1-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. g++ -std=c++0x -Wl,--dynamic-list-cpp-typeinfo -shared -o libfoo.so epptso.ii

  
Actual results:
collect2: ld terminated with signal 11 [Segmentation fault], core dumped

Additional info:

Comment 1 Caolan McNamara 2011-08-12 08:43:41 UTC
-O1 or -O2 and no crash. 

Interestingly this gets built (since 2000) with gcc as a special case in the OpenOffice.org/LibreOffice build. i.e. that at some point before 2000 it probably crashed an ancient gcc.

Comment 2 Nick Clifton 2011-08-12 16:07:40 UTC
Hi Caolan,

  Please try binutils-2.21.53.0.1-4.fc16.  You will probably get an error message like this:

   epptso.o: relocation R_X86_64_32S against `.rodata' can not be 
     used when making a shared object; recompile with -fPIC
   epptso.o: could not read symbols: Bad value

Which may not be what you are expecting, but I believe that it is correct.  At least the linker should not seg-fault now.

Cheers
  Nick

Comment 3 Caolan McNamara 2011-08-12 16:18:26 UTC
I probably should have said that
g++ -O0 -fPIC/-fpic -std=c++0x -Wl,--dynamic-list-cpp-typeinfo -shared -o libfoo.so epptso.ii
died as well with the original

but its of no matter to me, removing the archaic -O0 workaround for some other ancient bug was sufficient to build, so probably won't trigger it again one way or the other.

Comment 4 Michele Baldessari 2011-11-15 22:21:49 UTC
Hi Nick,

just as a confirmation: with binutils-2.21.53.0.1-5.fc16 compiling OOo doesn't segfault any more at all

thanks a lot and regards,
Michele

Comment 5 Fedora Update System 2011-12-14 12:09:18 UTC
binutils-2.21.53.0.1-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/binutils-2.21.53.0.1-6.fc16

Comment 6 Fedora Update System 2011-12-14 23:33:31 UTC
Package binutils-2.21.53.0.1-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing binutils-2.21.53.0.1-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17104/binutils-2.21.53.0.1-6.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-12-21 17:01:11 UTC
binutils-2.21.53.0.1-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.